0

i just copied working folders and files from Ubuntu to windows and whenever i try run the project am getting error like:

Fatal error: require_once(): Failed opening required 'D:\xampp\htdocs\geedel\errors\report.php' (include_path='D:\xampp\htdocs\geedel\app\code\local;D:\xampp\htdocs\geedel\app\code\community;D:\xampp\htdocs\geedel\app\code\core;D:\xampp\htdocs\geedel\lib;D:\xampp\php\PEAR') in D:\xampp\htdocs\geedel\app\Mage.php on line 925.

Any help would be greatly appreciated

2

Please check if you have a folder named errors on your magento root and whether there is a php file named report.php (probably someone had added entire errors folder to the gitignore or something? Just guessing).

0

You're running into an error during execution which is generating a report. While running in "production" mode, errors will not be shown on screen; instead, they're logged to files under var/reports/ and a reference to that report number is shown to the user in the output of report.php.

It appears that you're missing the required errors folder which will provide the logging and the error display. There are two ways to fix this:

  1. Copy the missing errors folder to your new installation
  2. Force Magento into "developer" mode and show the errors on screen.

To force Magento into developer mode you can do one of two things:

Set Environment Variable and Force Developer Mode

In your virtual host settings, you can specify the environment variable MAGE_IS_DEVELOPER_MODE and set its value to anything you want. As long as it's set, Magento will use developer mode and show you the errors on screen.

To set it in nginx, you can include the line below in your \.php$ block:

fastcgi_param MAGE_IS_DEVELOPER_MODE 1

For Apache, you would add this to your virtual host definition

SetEnv MAGE_IS_DEVELOPER_MODE 1

Modify index.php and force Developer Mode

Alternatively, if you want a quick fix and it's only temporary, you can edit index.php at the root of the Magento installation and on line 69 you should see:

 if (isset($_SERVER['MAGE_IS_DEVELOPER_MODE'])) {
     Mage::setIsDeveloperMode(true);
 }

Just change that if statement to be true and you'll be in developer mode. For example:

if (true || isset($_SERVER['MAGE_IS_DEVELOPER_MODE'])) {

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.