If I use an online redirect checker like redirect-checker or seobook.com I do get a "SERVER RESPONSE: HTTP/1.1 302 Moved Temporarily" for all pages, even for the homepage.

I tried to fix it by modifying .htaccess:

#RewriteRule .* index.php [L]
RewriteRule .* index.php [R=301,L]

But this results in a "broken" redirect like:


Further I changed

System -> Configuration -> Web -> Url Options

and set "Auto-redirect to Base URL" to 301 (before 302). Cleared ALL caches in backend and var/cache - The online checker still show the same - 302.

Any ideas how to fix the issue? Thanks!

1 Answer 1


I fixed it - in my case a GEO Location extension was responsible for the issue.

Anyway - to check in general I recommend to take a look in

  • .htaccess
  • index.php
  • search for keywords like "controller_action_predispatch" events, "header('Location:" or ""HTTP_X_FORWARDED_FOR" to identify related extensions and disable these.
  • thanks its work for me , issue was geo location Jan 16, 2019 at 8:06
  • how did you resolve the issue in geolocations extension?
    – Mohit Rane
    Jan 28, 2021 at 13:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.