1

In Description image not showing frontend

<img src="{{media url=" wysiwyg="" a.png"}}"="" alt="" data-pin-nopin="true">

I add description image in backend but frontend it's not showing. Even i set File Permission also 777 But no result

5
  • Sorry I am not getting – user38506 Apr 13 '16 at 7:32
  • where are you adding this image in text area? – Qaisar Satti Apr 13 '16 at 7:32
  • <img src="/media/wysiwyg/a.png" alt="" data-pin-nopin="true"> you are using the textarea not static block so url is not rendering. – Qaisar Satti Apr 13 '16 at 7:34
  • Ya it's working Y media url not working – user38506 Apr 13 '16 at 7:36
  • add the answer kindly follow that for media url. – Qaisar Satti Apr 13 '16 at 7:38
1

you have to add complete url of image

<img src="/media/wysiwyg/a.png" alt="" data-pin-nopin="true">

With URl Media or Skin you have to use getBlockTemplateProcessor()

<?php echo Mage::helper('cms')->getBlockTemplateProcessor()->filter($_product->getDescription()); ?>
0

replace your code from

<img src="{{media url=" wysiwyg="" a.png"}}"="" alt="" data-pin-nopin="true">

to

<img src="{{media url="wysiwyg/a.png"}}" alt="" data-pin-nopin="true">
3
  • <img alt="" src="{{media url="wysiwyg/a.png"}}" /> this is my backend url but front end it automatically change – user38506 Apr 13 '16 at 7:23
  • @MagentoDev I believe you are not doing it correctly please see here magento.stackexchange.com/a/5045/21339 – Arunendra Apr 13 '16 at 7:25
  • 1
    Let me explain i add one textarea attribute there i add image <img alt="" src="{{media url="wysiwyg/a.png"}}" /> then i call front end there it's not showing show i check inspect element it show in this way <img src="{{media url=" wysiwyg="" a.png"}}"="" alt="" data-pin-nopin="true"> – user38506 Apr 13 '16 at 7:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy