1

I just setup a test installation for Magento2 using Varnish 3. All seems to work fine but one thing is really strange:

If i register a new account i got the messages box telling me "Thank you for registering with Main Website Store.". This is fine on the first redirect, when registration is completed. But it always is showing up on any page.

The div container with class "page messages" is still getting delievered to the browser.

I used the default.vcl from the Magento backend, copied it to /etc/varnish/default.vcl (as this file is used by starting varnish). Is there anything else to do like the old -p esi_syntax=0x2 and cli_buffer? I used em both, but still i got this messages.

EDIT: I have opened a new browser incognito window and out of sudden in the incognito window i can't reproduce this 'error'. But still happening in the normal window, which wasn't closed all the time.

4
  • No idea anybody? Just wondering, if this is normal?
    – Michael
    Apr 14, 2016 at 16:46
  • I've been experiencing this as well on Varnish 4. It seems that somehow message is not cleared from local storage, and is always displayed. If I manage to find a solution, I'll post it here.
    – epson121
    May 6, 2016 at 11:01
  • I also face this problem, did you already find a solution?
    – Silvan
    Oct 4, 2016 at 14:34
  • not yet so far, as i had to drop working on this projects by now. I try to get some spare time to give it another testing round (probably it was caused by this early version of Magento2 and is fixed meanwhile).
    – Michael
    Oct 7, 2016 at 8:23

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.