0

I have a search autocomplete to search a products. If it works other modules are not working (banner slider, brand logo slider, product slider, sticky menu and sticky header).

autocomplete has 2 js files:

  • js/ves_autocomplete/noconflict.js
  • js/ves_autocomplete/ui/jquery-ui-1.8.16.custom.min.js

Banner slider has 4 js files

  • js/jquery.js
  • js/base.js
  • js/lightslider.js
  • js/homePage.js

Menu has 2 js files:

  • js/menu/jquery-1.js
  • js/menu/menu-jquery2.js

Sticky Header, Menu have

  • jquery/2.1.3/jquery.min.js
  • jquery/1.9.1/jquery.min.js
  • js/stickyMojo.js

When I just hide all the other js fileson my site, search autocomplete works; but i need to keep this design. Does anybody have an idea to solve this problem?

0

Each of the modules registers several jQuery-files, and in the end you have several different versions on you page. This results in Javascript errors, you can see them when you open Firebug, or your browser's developer tools.

There are also some other errors on the site, and I am not sure if they come from the jQuery-files; looks like some of the plugins are using the noConflict()-mode, and others don't.

You should make sure that you only have one jQuery-version included in you design.

| improve this answer | |
  • can you suggest one jquery version to all ? – Vijayakumar Apr 12 '16 at 10:29
  • No, sorry. I would always aim to use the highest stable version available; however, some of your modules might not be compatible with the newest version. The challenge now is to find a version that all of the modules work with. I personally have had very few problems with 1.9 in most of the cases I had this problem. – simonthesorcerer Apr 12 '16 at 10:31
  • oh god i need to find the problem where it is. – Vijayakumar Apr 12 '16 at 10:40
  • If you'd have a problem finding a one version that all modules works on you can give a try the jquery-migrate version. – versedi Apr 12 '16 at 12:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.