1

The Magento cron job is throwing error.

PHP Warning: PHP Startup: Unable to load dynamic library '/usr/local/lib/php/extensions/no-debug-non-zts-20121212/mcrypt.so' - /usr/local/lib/php/extensions/no-debug-non-zts-20121212/mcrypt.so: cannot open shared object file: No such file or directory in Unknown on line 0

the file is not there do to cpanel compiling it into apache. Any help would be appreciated I have no idea how to resolve this.

Apache 2.2 PHP 5.5

0

Please try disabling the extension in the config. To find the appropriate configuration, try this

grep -Hrv ";" /etc/php5 | grep -i "extension=" | grep mcrypt

Once you find the file(s), simply comment it out using a ; in the beginning of the line and restart apache. Since it is a cronjob throwing up the error, you may have to comment out mcrypt.so from /etc/php5/cli/conf.d/mcrypt.ini

2
  • when I grep /etc/php5 I get No such file or directory. this is a godaddy vps so the setup my be slighlty different, I'll look for the php5 directory and try again – Anthony Apr 11 '16 at 19:02
  • I disabled the extension in my ini and the issue appears to have gone away. I ran a magento requirements test and everything checked out. – Anthony Apr 13 '16 at 3:36
0

Mcrypt is a PhP library, which is required for Magento even on installation. So you should contact hosting support, or install this extension by yourself on server or local machine.

Here is instruction https://stackoverflow.com/a/18553415/4945184

PS and don't forgot to restart web server after all

1
  • I followed this link and tried everything plus and I can't get this. The module is referred to in the php.ini (extension=mcrypt.so) but that's as far as I can get – Anthony Apr 12 '16 at 0:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.