1

I have upgraded my Magento application form v1.7 to v1.9. Its running and I can login form admin. But when I am trying to add/edit user from System->permssions->user then It returns an error saying Current password field cannot be empty. See the attached screen.enter image description here

Please help me.

1

Find the your template path and paste the following code:

<?php echo $this->getBlockHtml('formkey') ?>

just after <form> tag, See how to enable the admin path hints.

| improve this answer | |
  • Hi, my path in is app\design\adminhtml\default\default\template\widget\form.phtml. But I added the above code to file after tags and clear cached but it didn't work. – Abhishek Apr 12 '16 at 12:25
  • Please share the file code – Arunendra Apr 12 '16 at 12:31
  • <?php /** * Magento * * DISCLAIMER */ ?> <?php echo $this->getBlockHtml('formkey') ?> <div class="entry-edit"> <?php echo $this->getFormHtml();?> </div> <?php echo $this->getChildHtml('form_after');?> – Abhishek Apr 12 '16 at 12:43
  • No this is not right file – Arunendra Apr 12 '16 at 12:45
  • Your code should look like : <form action="<?php echo $this->getUrl('*/*/saverole') ?>" method="post" id="role_edit_form"> <?php echo $this->getBlockHtml('formkey')?> </form> – Arunendra Apr 12 '16 at 12:47
0

In Magento 1.9 the edit user form should include a Current Admin Password field. See mine: (1.9.2.4)

enter image description here

I had the same problem until I removed a tacky extension, in my case it was Demac_AdminPermissions

I suggest you go in System/Advanced/Advanced and turn off any third party extensions you have one by one and see if any of them made this field go missing. When the field is back, the module you turned off last is the culprit, you can turn the others back on.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.