2

I am trying to use the new Magento 2 version and I have discovered that the form validator doesn't work as well.

When I try to add a product in the amdinistration panel I get this error:

Uncaught TypeError: $.validator.validateSingleElement is not a function

error

I have seen the requirejs-config.js and I can see the form validator. So why this happens?

code magento 2

The error seems to me clear but it's not so clear the solution for me. How have I to solve it?

thanks

1 Answer 1

3

I'm now running into the same problem, since I updated to 2.1. Before I also had this issue which I solved with that same fix. After that I saw the same error you're mentioning and it boiled down to being a local browser cache problem. So to fix it, try emptying your own browser cache. If that doesn't do the trick, first make sure you've deleted the magento cache and rebuild/recompile everything and try again. At least "it works on my machine".

1
  • 2
    Can confirm that deleting local cached fixed this issue. Commented Jul 27, 2016 at 6:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.