1

I'm seeing a strange layout-error in my backend. I try to add a new Page and this is what I keep seeing : https://i.stack.imgur.com/NW3Zv.png (the content for each tab get's loaded in the tab-space itself instead of next to it).

There are no console errors, I'm running in developer mode (2.0.4), have cleared the /var/ multiple times as well as reindexed/recompiled the whole installations; no luck.

I might figure it's a problem with the VES PageBuilder plugin, but I've had that installed for a while now, and this problem really just randomly popped up after a refresh. And now it won't go away.

Has anyone else seen this happen / have a fix for this?

Edit: I figured; let's see what goes wrong in the HTML of the page, maybe a tag didn't close or something. But that's the strangest thing; it looks like the content-edit screen is neatly tucked in an <li> item as the rest of them:enter image description here

2
  • Did you try run deploy static content command ? Apr 11, 2016 at 10:08
  • Yup, no luck. Still the same.
    – Asitis
    Apr 11, 2016 at 10:32

1 Answer 1

0

Edit: Nevermind, celebrated too soon. It went okay exactly one time, and the second time I'd open a page-editor - all is crooked again :(

Ok, my problem has sort of solved itself. I went on to delete the /var/ directory, redeploying content and compiling everything. It's strange, I got in to a loop of blank pages -> Error: Class X doesn't exist -> 500 error(s) etc.

At some point, after deleting the /var/ and clearing my browser cache, I got to see the admin-login form again. It kept redirecting me to the same form without any error, so after deleting the /var/ again, it works. The admin is now properly aligned again.

My best guess is that it has to do with the site running in Developer mode, pages take longer to load, and sometimes when a page doesn't load 100%, things like the layout can get messed up. Something in the generated/cache content of the Magento system there was an invalid or missing file/folder, that eventually came trough.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.