0

After Migrating my magento to new server. My Homepage is working and my admin page is also working. But all frontend pages will give 404 error. Note from initial server index.php has been removed. For example instead of //mydomain.com/index.php/one-page.html, we uses mydomain.com/one-page.html.

In the new server mydomain.com/one-page.html. is not working (Error 404) until you put index.php to it before it gives content on the page

Please what is the way out ?

2

The two "usual suspects" are either your .htaccess file and/or configuration settings within Magento.

Assuming you have mod_rewrite installed, ensure the following is present in your .htaccess file:

  <IfModule mod_rewrite.c>
  RewriteEngine On
  RewriteBase /
  RewriteRule ^index\.php$ - [L]
  RewriteCond %{REQUEST_FILENAME} !-f
  RewriteCond %{REQUEST_FILENAME} !-d
  RewriteRule . /index.php [L]
</IfModule>

Then, from the Magento Admin Panel, browse to System » Configuration, and then then General » Web.

Check the Use Web Server Rewrites setting under the Search Engines Optimisation is selected to "Yes".

Ensure the Base URL field in both Unsecure and Secure fieldsets are configured correctly, including trailing slashes, for example:

http://www.bluemwhitew.dev/

https://www.bluemwhitew.dev/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.