1

First I should say that there are many questions and answers on this topic around the web but I'm not finding anything close to what's happening here so I really hope someone here is able to help.

I have the wysiwyg disabled by default and when I click on Insert Image the pop up comes up as expected but is not fully rendered, see attached screen shot.

The console is saying Uncaught SyntaxError: Unexpected identifier, see attached screen shot.

Image Upload dialogue window

Console error

Prototype js error

I have disabled all extensions to rule out conflict + both media and wysiwyg folders have 777 permissions.

EDIT: I have tested Chrome, Firefox and Safari on Mac + Chrome on PC, all with the same result.

Just let me know if I left out any necessary info!

Big thanks in advance!

  • Have you tried a different browser? – pspahn Nov 19 '13 at 16:04
  • See my edit above. – Peter Svegrup Nov 19 '13 at 16:39
1

So after a day of diving into this issue; disabling modules, enabling modules, removing changes in local etc etc, I found the problem.

I used an extension called PhPro_Translate to do a large amount of translations for front and backend from English to Swedish and so in my std install I have just inserted all the rows of translations into core_translate (as the extension does). It turns out that one of the 80 or so translated strings under the Mage_Cms module cause the error. I honestly did not have the energy to look into exactly which string as I still have 3400 rows working :), but I have a vague idea it could have been a Swedish word with umlauts.

In the very unlikely event that someone else runs into the same problem, that's the answer!

Cheerio

UPDATE: Since this could have implications in other contexts, here's what caused the js error. In one of the translations I had used single quotes around a word to denote it was the original English term but I had forgotten to escape the quotes. Voilà!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.