0

My website is on one server.and mail is on different server.

My website is in Magento 1.9.2.3. It is now live on server and the order comes as the URL is same as old website.

But the problem is Mail has to be sent on new order to admin and customer too. Mail functionality is not working.

I have set System -> Configuration -> Store Email Address. and System -> Configuration -> sales -> Sales Emails

I have also set System -> Configuration -> Advanced -> System -> Cron(Schedule Task)

Still i don't receive any mail on new order [On admin side or as a customer]

I have also following steps which are in this video https://www.youtube.com/watch?v=GqRlXmBvvkE

I have also look that blog enter image description here

8
  • Is your cornjob working properly??
    – Asish Hira
    Commented Apr 4, 2016 at 6:11
  • How to check that? My website is on server now.Please provide me steps to check cronjob. Commented Apr 4, 2016 at 6:12
  • Have you tried to send test mail via root ??
    – Arunendra
    Commented Apr 4, 2016 at 6:14
  • New order mail is sent by cronjob in latest magento version.so you need to configure cron job on server Commented Apr 4, 2016 at 6:15
  • blog.nexcess.net/2010/10/03/… This link will help you check your cornjob status
    – Asish Hira
    Commented Apr 4, 2016 at 6:16

2 Answers 2

1

Yes, Magento after version 1.9.1 depend on cron to send order mail. Try install AOE Scheduler, https://www.magentocommerce.com/magento-connect/aoe-scheduler.html With this module you can if your cron is working or not. If not enable it by adding php /home//public_html/cron.php This is only example, try to point to your website directory.

0

check your cronjob working or not??

You can add this to cron.sh after the INSTALLDIR variable is set:

# absolute path to magento installation
INSTALLDIR=`echo $0 | sed 's/cron\.sh//g'`
date >> "$0".log
whoami  >> "$0".log

And this to cron.php after the dispatchEvent call:

Mage::dispatchEvent('default');
$log = fopen(__FILE__.'.log', 'a');
fwrite($log, date("Y-m-d H:i:s").PHP_EOL);
fclose($log);

After 6 minutes you should see both these files in Magento's directory if cron is running.

./cron.php.log
./cron.sh.log

If you have tried everything and still cant get cron to work, perhaps this unsupported workaround might help. Adding the following to the top of index.php will cause cron to run in the background whenever someone accesses your website.

<?php
$pathToCron = dirname(__FILE__)."/cron.sh";
exec( "sh $pathToCron > /dev/null &" );
Another workaround

*/5 * * * * /usr/bin/wget http://your_webpage.com/cron.php

Hope this helps

13
  • i have added code in both the files.But no any log file is created in magento directory.Any other solution? Commented Apr 4, 2016 at 7:36
  • Its means your cron job is not working. can you tell me your cron setting??
    – Ajay Patel
    Commented Apr 4, 2016 at 7:39
  • Yes but what do you want to know exactly ? & where is the cron setting located ? Commented Apr 4, 2016 at 8:11
  • go with this path : system->config->advance->system->cron. here you can see cron setting
    – Ajay Patel
    Commented Apr 4, 2016 at 8:19
  • Generate Schedules Every : 1 , Schedule Ahead for :1 , Missed if Not Run Within :15 , History Cleanup Every :120, Success History Lifetime : 120, Failure History Lifetime :120 Commented Apr 4, 2016 at 8:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.