I am using Magento 2.0.4, and whenever I click on Content>Elements>Blocks I receive the following error message: "Attention Something went wrong."

enter image description here

There is no more information, and after clicking OK it goes to the CMS Blocks page with the loading circle, and never stops loading. I am able to click on Add New Block button, and then create and save a new block, but those newly created/saved blocks do not show up in the Blocks page because it never fully loads.

Relevant Platform Install Info (can edit with more if needed): Magento version 2.0.4, PHP version 5.6.20

Browsers I've tested this issue on: Firefox 45.0.1, IE 11.0.9600.18231, Chrome 49.0.2623.110

This is a Magento install directly from the magentocommerce website, and not any kind of github download. After upgrading from Magento 2.0.2 to Magento 2.0.4 I already flushed everything, deleted static content, and ran the command to redeploy static content.

Please let me know what I'm missing here. Is this a permissions issue on the back end somewhere?, a coding issue, a known issue, or what is going on? I don't seem to be getting this error message when I click on anything else in the Admin Panel (for example, Pages, Themes, Widgets, and more all load correctly and generate no error message).

  • Removing the vendor and reinstalling was the only solution that worked for myself.
    – andy jones
    Commented May 31, 2017 at 14:41

11 Answers 11


You should check the var/logs folder to see if something went wrong and also your server logs.

For me the issue was related to this one https://github.com/magento/magento2/issues/5418.

Gone into db table cataloginventory_stock_item and delete duplicates and then the issue dissapeared.

If that doesn't solve it, you can try:

1) cd into pub/static and run find . -depth -name .htaccess -prune -o -delete

2) cd into root folder and run rm -rf var/cache/ var/generation/ var/page_cache/ var/view_preprocessed/

3) run php bin/magento setup:static-content:deploy

If this doesn't solve it you could take the radical option to reinstall:

1) delete the vendor folder rm -rf vendor/* and also the composer.lock file in root.

2) run composer install

  • +1 Worked for me. After the second step I refreshed the page and it was fixed. So i'm not sure if it was the first step or the second that actually fixed the issue. But most likely deleting the cache files manually is what helped. Guess cache:flush and cache:clean are not the same as rm -rf. I proceeded with the 3 step of deployment static content anyways and so far everything looks fine. Thank you. Commented Sep 19, 2017 at 19:20
  • The find -delete command is dangerous, it removed all of the files of my Magento installation. It should be removed/fixed in the answer.
    – karni
    Commented Mar 1, 2020 at 19:05
  • @karni it is not dangerous. it can't remove all files of your magento installation. if you read the answer it says cd into pub/static. if you do that it will only delete files inside static. which are meant to be deleted. Commented Mar 2, 2020 at 14:46
  • For some reason, I can't edit my previous comment. You're right (I didn't cd, but no worries, it was a fresh install). However, I assumed it would only nuke .htaccess files, whereas it seemed to work like rm -rf * and I was like "lol... wut" :D. Maybe it was nuked by some other bin/magento command. Apology for the confusion, this should pick up only .htaccess files, right?
    – karni
    Commented Mar 3, 2020 at 15:19
  • @karni no, it deletes everything in static folder except the .htaccess file, which you need and shouldn't be deleted. Commented Mar 3, 2020 at 15:21

Based on [ https://github.com/magento/magento2/issues/6602 ] you can:

  • uninstall the Magento and install it again. [OR]
  • go to database, find ui_bookmark table, delete all entries

Have just been debugging the exact same issue. When you see the

"Attention: Something went wrong"

message it will generate an error report inside var/report with more details on what went wrong. I would recommend that you delete all reports in that directory & refresh the page in your backend. This should generate a single report with more details.

In my case some page_id's from table cms_page didn't have a corresponding page_id in cms_page_store which resulted in the following error:

a:4:{i:0;s:137:"Notice: Undefined index: store_id in /path/vendor/magento/module-store/Ui/Component/Listing/Column/Store.php on line 82";i:1;s:7434:"#0 /path/vendor/magento/module-store/Ui/Component/Listing/Column/Store.php(82): Magento\Framework\App\ErrorHandler->handler(8, 'Undefined index...', '/path/ma...', 82, Array)
#1 /path/vendor/magento/module-store/Ui/Component/Listing/Column/Store.php(66): Magento\Store\Ui\Component\Listing\Column\Store->prepareItem(Array)

I was able to work around this by adding the missing page_id's & store_id's to path.


If it helps anyone, I solved this problem by disabling the NewRelic PHP reporting module.

The site was SSL enabled, with HSTS headers, and the javascript tracking code which the module was trying to inject was from a non-SSL endpoint. Once all non-SSL sources were removed, the Blocks page loaded happily.

There were no errors reported in var/reports var/log/exception.log or var/log/debug.log.

Strange that no other Magento admin pages seemed to be affected by this, possibly the error raised by inline javascript failing to be injected was also breaking Magento's ajax call.

Purely conjecture, but once NewRelic was disabled, the page loads perfectly


The most simple and easy solution is, like mentioned by @Helal just to go to the database and delete all entries in the ui_bookmark table.

Make sure you create a backup of your database so you can restore it if something goes wrong.

I have no additional information about why this is the solution. I tried the database solution as mentioned and it worked. Maybe somebody can explain the reason behind this?


In my case, it was permissions on the Notifications

enter image description here

  • 3
    Ahhhhhhhh!!!! I spent way too much time dealing with this error. Thank you for posting this. It fixed my problems. Magento Logic: 1) show a notification to user; 2) user doesn't have access to notifications; 3) ok, then show a notification telling the user they don't have access to notifications; 4) DID YOU NOT HEAR WHAT I JUST SAID? Commented Sep 7, 2018 at 17:07

I have a simple solution for it.

Follow steps->

1)First close pop up of something went wrong.
2)Then click on active filters and Inspect element and you will see here a class which enable background,bottom,position,z-index.....simply remove these attributes .
3)Now cross button is clickable in active filters and now we can remove filters from grid.Remove all filters and Open same page in new tab.

in my case I was getting same problem in sales->order section.I resolved same process

.admin__data-grid-loading-mask {
    background: rgba(255,255,255,0.5);
    bottom: 0;
    left: 0;
    position: absolute;
    right: 0;
    top: 0;
    z-index: 399;

and I disable some attribute by enabling inspect element for admin section
and new class was 

.admin__data-grid-loading-mask {
    left: 0;
    position: absolute;
    right: 0;
    top: 0;
    z-index: 399;

I had the "Something went wrong" error on Magento 2.1 when viewing a product edit page. In my case a search for the error message found that it was generated when an AJAX response failed, so I used the Chrome dev tools to find the specific AJAX response that was failing. This response had an error code of 500, which allowed me to look in the httpd error log (not the magento logs) to find that there was a PHP error (in my case, caused by the Magento profiler - disabling the profiler made the error go away).

Your error conditions may vary, but hopefully this process helps you find the cause.


For me it was an resource query issue, check your exception.log, in my case I mixed column names up:

[2020-04-01 02:02:15] main.CRITICAL: SQLSTATE[42S22]: Column not found: 1054 Unknown column 'id' in 'order clause', query was: SELECT `main_table`.* FROM `my_table` AS `main_table` ORDER BY id ASC
 LIMIT 20 {"exception":"[object] (Zend_Db_Statement_Exception(code: 42): SQLSTATE[42S22]: Column not found: 1054 Unknown column 'id' in 'order clause', query was: SELECT `main_table`.* FROM `my_table` AS `main_table` ORDER BY id ASC
 LIMIT 20 at vendor/magento/zendframework1/library/Zend/Db/Statement/Pdo.php:235, PDOException(code: 42S22): SQLSTATE[42S22]: Column not found: 1054 Unknown column 'id' in 'order clause' at vendor/magento/zendframework1/library/Zend/Db/Statement/Pdo.php:228)"} []


A possible solution for if you are facing in the area other than Admin - https://magento.stackexchange.com/a/364552/45519


For Magento CE 2.0.15, you can check file:


Line 110 ~ 112 :

    content: $t('Something went wrong.')

Hope this is helpful.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.