2

On the "Web Setup Wizard" there are two places to sign in:

1) Component Manager - via "Sign In" link. 2) System Config - via form.

Both forms ask for Public & Private Access Keys which I have generated as per the instructions here:

http://devdocs.magento.com/guides/v2.0/comp-mgr/prereq/prereq_auth-token.html

When I click "Sign In" button (on Component Manager page) or "Save Config" button (on System Config page) i get a message "Bad Credentials"

I have tried:

a) regenerating keys.

b) generating new keys.

c) generating a new magentocommerce.com account and generating new keys.

I have verified that I am copy/pasting the keys correctly, with no leading/trailing spaces, etc.

At the moment there is a critical update which I cannot update to because the System Upgrade requires a valid login for it to work.

Currently the system upgrade fails to download the file:

https://repo.magento.com/archives/magento/framework/magento-framework-100.0.5.0.zip

This upgrade failure requires a filesystem restore to fix and the installation is broken until the vendor/magento/framework directory is restored.

Suggestions on how to fix the login problem please?

  • I am also getting same erro message. – user38115 Mar 31 '16 at 20:22
  • Same here with the error message. Glad I'm not alone! – user2533212 Mar 31 '16 at 20:26
  • Same problem here :) – JonaPkr Mar 31 '16 at 21:08
  • I believe that access to repo.magento.com is restricted for everyone right now while we issue a 2.0.4 patch. Sorry for the inconvenience. – Steve Johnson Mar 31 '16 at 22:28
  • 1
    The Magento "Copy Key" adds a space at the beginning of the keys, so copy the two keys manually and carefully exclude any whitespace in front and end. – Cedric Meury Jun 16 '19 at 18:50

Browse other questions tagged or ask your own question.