0

The webhost which looks after a magento instance messed up all of the file ownerships and permissions. They have now stated they have sorted it out and we can now FTP in and upload files. The issue we have now though is that when a customer updates the quantity in the cart it doesnt work.

Looking at other posts it would seems to lead to the form_key field however I can see this field in the source code eg:

<form action="https://www.example.co.uk/checkout/cart/updatePost/" method="post">
<input name="form_key" type="hidden" value="BRTMA77qNzgbkgDT" />

So I dont believe its that.

I have tried to clear all magento and browser cache but no luck. Has anyone got any suggestions.

Update I think the issue is with _validateFormKey function in /app/code/core/Mage/Core/Controller/Varien/Action.php

If I dump out the values

zend_debug::dump($_POST);
zend_debug::dump($this->getRequest()->getParam('form_key', null));
zend_debug::dump(Mage::getSingleton('core/session')->getFormKey());

I get

array(0) {
}
NULL
string(16) "BRTMA77qNzgbkgDT"

So it looks to me the POST is being cleared but not sure why

  • Have you checked the error logs for errors? – Barry Carlyon Mar 30 '16 at 8:59
  • Yea nothing in there unfortunately – Goose84 Mar 30 '16 at 9:01
  • have you added custom form to cart qty update or using magento default? – Abdul Mar 30 '16 at 9:58
0

No idea what was wrong, I re-uploaded all the files again and it worked. I still think it was related to permissions

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.