1

I am making a custom theme and for no reason at all, I am now getting :

jQuery.easing[this.easing]

I wasnt previously getting this. Any Ideas?

Below is my requirejs config file:

var config = {
    map: {
        '*' : {
            owlcarousel  : 'js/owl-carousel/owl.carousel',
            easing:        'jquery/jquery-ui',
            customscript : 'js/custom'
        }
    },
    paths:{

            'owlcarousel'  : 'js/owl-carousel/owl.carousel',
            'easing':        'jquery/jquery-ui',
            'customscript' : 'js/custom'


    },
    shim: {
           'owlcarousel': {
                deps: ['jquery']
            },
            'easing': {
                deps: ['jquery']
            },
            'customscript': {
                deps: ['jquery']
            }
    }
};


    require([
        'jquery',
        'easing',
        'owlcarousel',
        'customscript',
    ], function ($) {  

          $(document).ready(function () {

            // -- Hero Carousel
           $("#owl-demo").owlCarousel({
                nav: true,
                items: 1,
                loop:true,
                autoplay:true,
                autoplayTimeout:3000,
                autoplaySpeed: 3000,
                autoplayHoverPause:true
            });

           // -- Sub Navigation

           openSubNav($);

        });
    });

The Problem occurs when I am calling the function openSubNav($); however it has previously worked. I added jquery ui to the map after a previous suggestion but still not working

0

I solved this. I am not sure why it worked before and not now, however the slideToggle function in my custom.js file I added

slideToggle('slow', 'linear' function(){} );

The linear was the addition that made it work.

Hope this is useful to someone

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.