1

I have created one CMS page for showing coupon code information in Magento. It was successfully created.

But when I open that CMS page, it will be opened another user account’s coupon information. But other links are working correct.

In the url(http://www.example.in/coupon/), if I put "/" at the end its working correct from the account def@gmail.com. When I open that link from the account “abc@gmail.com” that CMS page open with the "def@gmail.com" account's information. But if I remove that "/" at the end, its working correct from the account "abc@gmail.com". When I open that link from the account “def@gmail.com” that CMS page open with the "abc@gmail.com" account's information.

I don’t know, why it’s come like this.

Please help me.

  • Maybe some full page cache configured wrongly? – Marius Nov 15 '13 at 6:56
  • How to resolve this problem? – DRAJI Nov 15 '13 at 7:13
1

This looks like a full page cache issue.
A solution would be to create a custom module that displays this information and make that module not cache-able.
You can also try to make that specific page not cache-able but I guess this approach is riskier.
You can find here a small example on how you can create a module with a page. The example is for a page with a form but you can adapt it to display your desired content.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.