6

I am trying to upgrade all packages via Magento Connect Manager but keep getting the following:

Checking dependencies of packages

CONNECT ERROR: Package community/Phoenix_Moneybookers 1.9.2.4 conflicts with: community/Mage_All_Latest 1.9.2.2
Package community/Mage_Core_Modules 1.9.2.4 conflicts with: community/Interface_Frontend_Base_Default 1.9.2.2, community/Interface_Frontend_Default 1.9.2.2, community/Interface_Frontend_Rwd_Default 1.9.2.2, community/Interface_Install_Default 1.9.2.2, community/Mage_All_Latest 1.9.2.2, community/Mage_Centinel 1.9.2.2, community/Mage_Compiler 1.9.2.2, community/Mage_Core_Adminhtml 1.9.2.2, community/Magento_Mobile 1.9.2.2, community/Phoenix_Moneybookers 1.9.2.2
Package community/Lib_Varien 1.9.2.4 conflicts with: community/Mage_Core_Modules 1.9.2.2
Package community/Lib_Google_Checkout 1.9.2.4 conflicts with: community/Mage_Core_Modules 1.9.2.2
Package community/Lib_Js_Calendar 1.51.1.5 conflicts with: community/Mage_Core_Adminhtml 1.9.2.2, community/Mage_Core_Modules 1.9.2.2
Package community/Lib_Js_Mage 1.9.2.4 conflicts with: community/Mage_Core_Modules 1.9.2.2
Package community/Lib_Phpseclib 1.9.2.4 conflicts with: community/Mage_Core_Modules 1.9.2.2
Package community/Mage_Locale_en_US 1.9.2.4 conflicts with: community/Mage_Core_Modules 1.9.2.2
Package community/Lib_Mage 1.9.2.4 conflicts with: community/Mage_Core_Modules 1.9.2.2
Package community/Lib_Magento 1.9.2.4 conflicts with: community/Mage_Core_Modules 1.9.2.2
Package community/Lib_Credis 1.9.2.4 conflicts with: community/Cm_RedisSession 1.9.2.2, community/Lib_Cm 1.9.2.2, community/Mage_Core_Modules 1.9.2.2
Package community/Lib_Pelago 1.9.2.4 conflicts with: community/Mage_Core_Modules 1.9.2.2
Package community/Lib_Unserialize 1.9.2.4 conflicts with: community/Mage_Core_Modules 1.9.2.2
Package community/Lib_IDNA2 1.9.2.4 conflicts with: community/Mage_Core_Modules 1.9.2.2
Package community/Lib_ZF 1.12.10.4 conflicts with: community/Lib_Varien 1.9.2.2
Package community/Lib_Js_Prototype 1.9.2.4 conflicts with: community/Lib_Js_Mage 1.9.2.2, community/Mage_Core_Modules 1.9.2.2
Package community/Lib_ZF_Locale 1.12.10.4 conflicts with: community/Lib_ZF 1.12.10.2

I have deleted /pkginfo/Mage_All_latest.txt as per other suggestions I found, but nothing changes. How I can I fix this?

17

Delete pkginfo/Mage_All_latest.txt and then from magento connect try to upgrade only mage_all_latest only.. It will upgrade everything successfully without any issues.

I did same and it worked.

Let me know if you need help.

  • Hi, tried this, but ended with partially deleted magento files. I had backup so I rolled back, but I'm not sure what was the reason for this deletion. – Sharif Jul 14 '16 at 17:43
3

I deleted pkginfo/Mage_All_latest.txt and then from Magento Connect, upgraded Mage_All_Latest to 1.9.2.4 and it upgraded everything successfully without any issues.

1

In my case there were files that couldn't be replaced because they were considered folders instead of files. Check the errors from the upgrade, as they are giving you instructions on what to delete: upgrade-all: Failed to delete files:

public_html/./app/design/adminhtml/default/default/template/xmlconnect//edit/tab/design/preview/banner_rotator.phtml

public_html/./app/design/adminhtml/default/default/template/xmlconnect//edit/tab/design/preview/catalog_android.phtml

and this is why the upgrade fails. Connect ftp to your server and delete them. Remove them and give again the uprade command: ./mage upgrade-all --force

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.