I've been running into this issue lately where I cannot save content in a CMS page if it contains the word 'Select' or any variant of the page. Whenever I try and save a page with the word 'Select in the content area it does the typical refresh but does not say that the page has been saved as usual and the content will revert back to whatever it was before the updated content was put in.

Also if it is a new page it will not create the page when you try and save.

I'm not entirely sure about this but it seems that it may be a copy and paste issue with the word select. I've tried hand writing small portions of code containing 'Select' and it will save sometimes.

I've also tried replacing the word select with anything else and it will save the page but when I try and add select back inside of magento it does not save the page.

The only workaround I have at the moment is to write the content directly into the database but this is not sufficient because our client needs to be able to update content as well.

Any ideas? Suggestions?

Additional Information: Looks like I've found another set of words that won't save 'From Effect'

  • Assuming the core files have not been changed and you have a test copy of the site I would disable all community and local modules and see does A CMS page save with the word "select". If it does you will know its a module issue and you can start re-enabling modules until you find the culprit. Otherwise it could be a database issue but I don't see how Magento wouldn't save CMS content with the word select. – Colin Murphy Mar 22 '16 at 20:31
  • Do you have the wysiwyg editor enabled? And can you post the page content that you are saving? Magento will do content scanning when you save a cms page or block (that's why sometimes it will add in <p> tags). It might be there is a HTML error in the code that is stopping this validation. – circlesix Mar 4 '17 at 22:08

try this, Go to System - configuration - Advanced (Developer) - Merge java-script setting - No (You can turn it on after saving your cms page).

  • It looks like it's already set to no for us. – Enigma Mar 22 '16 at 20:55
  • have toy tried the same thing with css option ??? If you can provide me the error screenshot, it would easy to solve the issue – Aditya Mar 22 '16 at 20:57
  • The issue is that it's not giving off any error that we can find. When we save the page it refreshes the page as if it saved but does not have the box saying it was saved and no content was updated. I will try the css option. – Enigma Mar 22 '16 at 21:02
  • No luck with that. – Enigma Mar 22 '16 at 21:09
  • very strange.... can you share page.phtml with me – Aditya Mar 22 '16 at 21:12

i am working on magento 1.9 and faced the same issue once,in my case clearing browser cache and cookies helped me !

Not the answer you're looking for? Browse other questions tagged or ask your own question.