0

I had attempted to import categories into my magento using SQL, but looks like it hasn't worked. In manage categories section it looks like this:

enter image description here

The numbers suggest correct product linking but other than that broken, clicking the expand button also does nothing.

**UPDATE: **

I have got the categories, and sub-categories to display. But the products although correctly showing in the count next to the categories, they are not appearing when I click on the actual category and got to the category products tab:

enter image description here

  • Check category is active or not – Magento 2 Mar 21 '16 at 12:40
  • the categories seem malfunctioned. They should be set to active, and the name of the categories isn't even showing. – Vaishal Patel Mar 21 '16 at 12:42
  • I don't know what is the exact problem try to reindex once and clear cache / Session – Magento 2 Mar 21 '16 at 12:45
  • @Kothari attempted reindex, get trouble in that the category flat data index wont reindex. Looking at the exceptions.log get: Exception message: Notice: Undefined offset: 67 in /app/code/core/Mage/Catalog/Model/Resource/Category/Flat.php on line 833 – Vaishal Patel Mar 21 '16 at 12:52
  • Check that error in google – Magento 2 Mar 21 '16 at 13:00
0

I solved this issue by ensuring the eav attributes references were correct. Both installations had referenced attributes in different rows, thus the references needed updating in the category tables.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.