0

I found the following answer regarding import of related products (How to import related products in normal import process?). The answer suggests that it is possible to perform this type of import and recommends manually adding some examples via the Magento admin in order to see how the related fields are populated.

I performed a manual related product association and can see the related product in the back and front end, but upon export, the links_related_sku and links_related_position fields are empty.

I have since tried an import with an SKU in the links_related_sku field via Magmi, which was unsuccessful.

Am I doing something incorrectly or is the related products export/import "buggy"?

  • did @marius not just recently tweet about a tool he wrote for importing related products? yes he did: github.com/tzyganu/ProductRelationsImport – ProxiBlue Nov 13 '13 at 0:01
  • If you use my extension that @ProxiBlue mentioned make sure you back-up your database first. It's still experimental and I'm waiting for feedback to see how it works for other people. It seamed to work for me. – Marius Nov 13 '13 at 8:47
3

The magmi column for importing related products is re_skus (or xre_skus) as specified in the "related" plugin documentation.

  • how to exclude products from "related". – ravi patel Feb 2 '16 at 6:03
0

Import Ralated Product, Import Up-sells Product, Import Cross-sells Product, Import Custom Options Product, Import Other Product Data.

  1. Export Products File.
    Goto: System -> Import/Export -> Export

  2. Import Products File.
    Goto: System -> Import/Export -> Import

Path: /app/code/core/Mage/ImportExport/Model/Import/Entity/Abstract.php

  1. Find Function

    public function isDataValid()
    {
        $this->validateData();
        return 0 == $this->_errorsCount;
    }
    
  2. Replace With

    public function isDataValid()
    {
        $this->validateData();
        return 1;
    }
    
0
  1. Change the csv sheet column 'links_related_sku' to ' re_skus' then try importing!
  2. re_sku column change column format to 'text'(Excel->right click on column ->format cells -> select 'text')
  3. Remove space after each comma.
  4. Save the sheet and import from magmi.

I think this will solve problem!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.