1

Hello I have installed Magento2 on my local Server in Ubuntu 14.

I downloaded it from official magento website without sample data.

I installed it and I am got this screen enter image description here

When I clicked on frontend url i got this screen enter image description here

When I clicked on Admin Url I got this screen enter image description here

I am not getting what went wrong from my side any help will be appreciable

  • run cli php bin/magento setup:static-content:deploy – xanka Mar 18 '16 at 6:33
  • it is not working similar problem i am facing – PRashant PUrohit Mar 18 '16 at 7:12
  • u can delete everything pub/static except .htaccess then run cli php bin/magento setup:upgrade. – xanka Mar 18 '16 at 8:05
  • after running this command i got this error --- The localhost page isn’t working localhost is currently unable to handle this request. 500 – PRashant PUrohit Mar 18 '16 at 9:11
  • check Apache's mod rewrite... do you have an .htaccess file in your document root? is Apache's mod rewrite enabled? AllowOverride? – FlorinelChis Mar 25 '16 at 12:04
1

Go to Database in "core_config_data" table there is "web/seo/use_rewrites" set it to 0.

after that clear cache:

bin/magento cache:flush

reindex all:

php bin/magento indexer:reindex

Use url: http://localhost/MagentoCE/index.php/admin

Give permission to pub folder

chmod 777 -R pub 

after that delete below folder

var/view_preprocessed

var/cache

pub/static/frontend/Magento

After deleting folder run below command

php bin/magento setup:static-content:deploy
  • it worked prashant but still my css is not loading please suggest something for that also – PRashant PUrohit Mar 18 '16 at 7:28
  • Check in console any 404 error for css? – Prashant Valanda Mar 18 '16 at 7:40
  • didn't get please elaborate – PRashant PUrohit Mar 18 '16 at 7:55
  • view source (using cntrl + u) open css link. It is working or any error there – Prashant Valanda Mar 18 '16 at 9:26
  • 404 error coming when I clicked on css link – PRashant PUrohit Mar 18 '16 at 9:29
1

Try this Before that take Backup

  1. Remove everything, except .htaccess file from pub/static folder

  2. Open up app/etc/di.xml find the path “Magento\Framework\App\View\Asset\MaterializationStrategy\Symlink” and replace to Magento\Framework\App\View\Asset\MaterializationStrategy\Copy

Note: Remove entire files and folder under pub/static except .htaccess file.

For More info ref this http://www.dckap.com/blog/magento-2-admin-links-not-working-in-windows/

0

Visit http://www.dckap.com/blog/tag/magento-2-admin-links-not-working/ for the solution I think it will help you.

0

I solved this problem i ran 2 commands after installing Magento 2

sudo php bin/magento setup:static-content:deploy

sudo find . -type d -exec chmod -R 777 {} \; 
&& sudo find . -type f -exec chmod -R 777  {} \; 
&& sudo chmod u+x bin/magento

Now its working fine thank you all of you for answering

0

Run this Query in database :

INSERT INTO core_config_data (path, value) VALUES ('dev/static/sign', 0) ON DUPLICATE KEY UPDATE value = 0;

Then Run:

php bin/magento cache:clean
php bin/magento cache:flush

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.