0

I was working on a new magento shop but im having issues configuring tax.

I have congured that the admin fills in prices including tax. Also the view settings are configured showing including tax.

I fill in 10 euro as normal price in the admin. I leave special or group / tier price alone. But on the front-end it shows the total price is (10 * 1.21) 12,1 euro.

Product price config back-end:

Product front-end:

Tax settings: enter image description here enter image description here

I removed all external modules and theme's. The product i use in the screenshot is created without external modules.

If i echo

$product = Mage::getModel('catalog/product')->load('3');
echo $product->getPrice();
echo "_______________ <br>";
echo $product->getData('price');

It will echo the right price of the product, including tax which is 10.

I'm getting really desperate.. what am i doing wrong?

Magento Community 1.9.2.4

  • Product backend: i.imgur.com/u35rjQh.png Product frontend: i.imgur.com/hUlCTVE.png – Jordi van der Pluijm Mar 17 '16 at 18:06
  • Can you give more information please. Can you upload a screenshot of the "Tax Rates", the "Tax rule" for your store and also what the default customer group is for your store. – Colin Murphy Mar 17 '16 at 18:43
  • Thanks for your reply. Below extra information. Tax rates and rules: i.imgur.com/1MBxYhe.png Customer groups: i.imgur.com/RT9cRtm.png The default group is General. – Jordi van der Pluijm Mar 17 '16 at 19:36
  • I noticed that shipping costs have the exact same issue. I filled in 6,95 euro including tax for flat rate shipment. On the front-end the shipping costs are 8,41 euro. – Jordi van der Pluijm Mar 17 '16 at 19:45
  • Well the shipping rate is charging 21% VAT. Can you reindex your site and clear the cache and see what price is now showing for the product? If its still the same can you send me a screenshot of the edit page of the tax rule which is charging 21% and leave me know if there are other other tax rules under Catalog -> Tax -> Manage Tax Rules – Colin Murphy Mar 17 '16 at 19:55
0

I think the answer is to enable cross border trading! Had the same problem and this setting solved it for me! Go to: System > Configuration > Tax > Calculation Settings > "Set Enable Cross Border Trade to Yes"

  • Apparently 1.9.1.0 and the versions later needs Cross border trade to be set to "Yes" for the price to shown correctly. – Felix Kruse Mar 18 '16 at 9:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.