0

I copied a whole magento installation to a local environment to test some developments. After I reset the database connection and base path of the installation, it's impossible to call a product page.

First I got the following error:

"Maximum function nesting level of '500' reached, aborting! in /app/Mage.php on line 750"

I found out, that it could be a problem with xdebug installed on my server. So I uninstalled it, but that wasn't the problem. Now the page tries to load, but it never comes to an end. I added some exits in the core files, to find out where it breaks. It's in /app/code/core/Mage/Catalog/Helper/Product/view.php on line 73 which is called in the product controller:

$controller->generateLayoutXml()->generateLayoutBlocks();

Anyone an idea what's going wrong here? Magento Version is 1.8.1.0.

Thanks in advance!

1 Answer 1

0

You'd find any catalog_product_viewreference (and / or sections inside) in your layout files to see what's trying to be loaded...

In addition to this, check for any extension affecting product view layout. It seems there are lot of blocks being injected

2
  • I searched for catalog_product_view in all xml files and of course it was the problem. A module called factfinder injects a block into the content of the product page although the module is deactivated?! If I comment out the layout update it works... Commented Mar 16, 2016 at 10:13
  • Glad it helped ;) Commented Mar 16, 2016 at 11:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.