0

Magento 1.9.0.1 SUPEE-6788 SUPEE-7405

Hi

Since i've installed the latest patches of magento, instead of the 4 basic scopes default.php/catalog.php/checkout.php/cms.php, i've got 13 default/cms/catalog/checkout/adminhtml/contacts/sales/configurator/customer/reviewemail/authorizenet/firewall/api. And if i enable it, i get a blank page when i try to click on the system/configuration tab in admin.

I've tried everything : Flush, recompile, disable local module..etc. Nothing works and it doesn't give me anything in log/debugging/display errors.

So i was thinking, what if i change the compiler core file to only compile the 4 basic scopes default.php/catalog.php/checkout.php/cms.php, it could at least work for the base and stop showing that error ?

I've read this article Correct Method of Flushing Caches & Managing the Compiler which explains in detail the working of compiler.

Hope somenone can help me, i've searched and tried everything.

Kind regards, Marc

  • Try to switch off compiler first – Minesh Patel Mar 15 '16 at 10:02
  • If admin is not working got to file magentoRoot/includes/config.php and comment out both line with # #define('COMPILER_INCLUDE_PATH', dirname(FILE).DIRECTORY_SEPARATOR.'src'); #define('COMPILER_COLLECT_PATH', dirname(FILE).DIRECTORY_SEPARATOR.'stat'); – Minesh Patel Mar 15 '16 at 10:04
0

Thank you both for your fast response.

I have access to the backend without any problem, only the tab system/configuration is not working. I can access the compiler tab, switch it off, turn it back on. But as soon as i click on the system/configuration tab i get a blank page.

I think it comes from the patches that scopes larger into the modules. And i'm sure that the MageFirewall security module is the source of the problem because i've uninstalled it without being able to get the database sql query to clean it. The creator at http://magefirewall.com/ just tells me to delete the files by FTP, but i still have the scope "Firewall" in my compiler. If i could get the list of database tables to truncat, i think i would solve my problem.

0

Know this is an old post, but if anyone is searching for this same thing - you can do the following.

Clear and disable compiler, then delete the stat folder inside /includes. Run compiler again, then it should default back to the 4 scopes.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.