0

It's a magento 12 ee build... I went into some core code and purposely changed a method for log exception purposes to see if i would throw and error. It broke my store (like i suspected) and i got the error message on the front end but it's not writing to my log.

System => Linux precise64 3.2.0-23-generic #36-Ubuntu SMP Tue Apr 10 20:39:51 UTC 2012 x86_64
Build Date => Apr 17 2015 15:09:58
Server API => Command Line Interface
Virtual Directory Support => disabled
Configuration File (php.ini) Path => /etc/php5/cli
Loaded Configuration File => /etc/php5/cli/php.ini
Scan this dir for additional .ini files => /etc/php5/cli/conf.d
Additional .ini files parsed => /etc/php5/cli/conf.d/00-ioncube.ini,

I just finished checking the permissions on the log folder and it's set to 755.

It's turned on = yes in system preferences of the admin panel.

public static function getVersionInfo()
    {
        return array(
            'major'     => '1',
            'minor'     => '12',
            'revision'  => '0',
            'patch'     => '2',

Any ideas?

0
  1. Edit index.php in magento root folder and find //error_reporting(0) and replace with error_reporting(E_ALL); ini_set('display_errors',1); and refresh the page. It should display the error.
  2. Check php error logs. It should be usually under i/var/log/apache2. Fatal errors will be reported there.
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.