6

Recently, after checking out the develop branch from Magento 2's github and running composer install, the composer installer ended with the following messages

start magento deploy via deployManager
jump over deployLibraries as no Magento libraryPath is set

Does anyone know what the deployManager these methods refer to is?

1
  • also the vendor/magento/module-* modules are not pulled
    – Radu
    Apr 14 '20 at 12:46
8

That is an outdated part of code which is not even used in magento 2.

It resulted from the fork of the composer installer for magento 1 which has multiple additional features to extend magento 1 via composer.

This specific feature allowed to put php libraries installed via composer into a director, analog to \lib\ and also added a static autoloading for them, allowing deployment or even comitting them to the vcs without the need for others to also use composer. This feature was/is experimental und was used from nearly noone

update this answer concentrated on deployLibraries setting, the deploy manager itself was just a logical processor for all files copied from composer to the magento directory, so it was able to do this process outside of the old installer but as an plugin event

1

To any one else getting the error messages mentioned by the OP: Simply delete the packages in the vendor directory and do a composer install.

This solved the issue for me after trying to initialize a M2 project that was provided to me by another developer.

Not sure what the issue was but re-loading all the packages surely solved it for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.