5

My Magento 2 was running normally, then I tried to change for production mode and I'm getting the following error:

Command returned non-zero exit code: 
`php -f /var/www/magento2.strip-curtains.com/public_html/bin/magento setup:di:compile-multi-tenant 2>&1`

When I run the command #php -f /var/www/magento2.strip-curtains.com/public_html/bin/magento setup:di:compile-multi-tenant 2>&1

[ReflectionException] Class \Smartwave\Megamenu\Model\Attribute\SubcatColumns does not exist
setup:di:compile-multi-tenant [--serializer="..."] [--extra-classes-file="..."] [--generation="..."] [--di="..."] [--exclude-pattern="..."] [--magento-init-params="..."]

I can only run the site if I set back to developer mode.

  • Same problem here. Seems to be a problem with a theme. Same output when I run the command manually: [ReflectionException] Class \Smartwave\Megamenu\Model\Attribute\SubcatColumns does not exist Smartwave is the vendor of a theme called "porto" which is quite popular. I will ask them and come back with their answer. Perhaps somebody already solved the problem here and can also help? – Marc Bohm Mar 13 '16 at 12:32
1

In this case I think you are running into one of three issues.

  1. You need to run php bin/magento setup:upgrade to update the list of modules in case you have removed or changed one. If you did remove the Smartwave module without resetting your app/etc/config.php it's possible to get this error.

  2. You have removed the Smartwave module but there is still code the uses some of it's classes or extends from it that haven't been updated.

  3. You need to clear that var folder's that could have old content in them. They are typically var/di, var/view_preprocessed, var/cache, var/page_cache, var/generation. Clearing these might solve the issue.

From here, I would grep for the use of the Smartwave module in the app and vendor folders and see what comes up to figure out where it's being used.

grep -r "Smartwave" app/*

  • I am confused about "Smartwave" and have same problem like. My issue: magento.stackexchange.com/q/161645/29175 – Jai Feb 27 '17 at 7:43
  • When you run the search, does anything come up? – circlesix Feb 27 '17 at 14:30
  • I am aware about all steps mentioned in answer but wanna know about Smartwave – Jai Feb 28 '17 at 3:43
  • oh, i have no idea what it is. looks to be a mega menu, but i'm only using that as it's in the error message in the orig post. – circlesix Feb 28 '17 at 4:06

protected by Community Mar 18 '16 at 9:30

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.