4

I installed magento 2.0.2 on WAMP 2.5 successfully but I see home/admin page takes at least 3-4 mins to get loaded and the case is same in page navigation. Kindly help me in getting my pages loaded faster . Below are my env details

OS:Windows 7 64 bit WAMP:2.5 RAM:8GB

Early helps are appreciated .

Thanks Kotresh NM

2
  • 2
    Are you running development, default or production mode? Mar 5, 2016 at 22:46
  • I use a Virtual Machine of Lubuntu; a Lightweight Linux OS - Good for developing on through Windows.
    – MackieeE
    Oct 6, 2017 at 12:35

2 Answers 2

1
  1. Do not use WAMP
  2. Do not use Windows

Use the Magento Dev Box: http://devdocs.magento.com/guides/v2.1/install-gde/docker/docker-over.html

Follow this guide: http://devdocs.magento.com/guides/v2.1/extension-dev-guide/build/optimal-dev-environment.html

0

Do the folowing:

  1. set production mode with gitbash cli in the magento root->bin folder : php magento deploy:mode:set production
  2. set static content files: php magento setup:static-content:deploy
  3. set di compile: php magento setup:di:compile
  4. After doing the above go to magento admin and "Flush Magento Cache"
  5. If you change any code(xml, phtml or css)
    a. go to magento root->var and delete folder "view_preprocessed"
    b. go to magento root->pub->static and delete all files and folder except .htaccess

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.