0

I'm running a development installation on MAMP PRO and when I'm trying to deploy:mode:set production it fails at setup:static-content:deploy. When running setup:static-content:deploy directly from CLI it succeeds without problems.

Any ideas what might be wrong?

Stack trace on GitHub.

1 Answer 1

3

I had the same issue.

I found that I had to change the MAMP php.ini file directly, rather than the template.

When I ran php -r "echo ini_get('memory_limit').PHP_EOL;” from within the root I wasn't seeing the memory limit that I changed in the MAMP template for the version of php I was using.

But when I went to Applications > MAMP > bin > php > [PHP VERSION] > conf > php.ini and edited the file there and ran php -r "echo ini_get('memory_limit').PHP_EOL;” again I was seeing the correct value.

Once I did that compilation worked and I was able to get Production mode set.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.