I installed Magento2 successfully through the commandline, but when i try to access the website, i get a Server Error 500.

The server runs on Ubuntu 14.04

I have no idea what is wrong, or what i am doing wrong. I used a script to install Magento2 so i expect it to be correct

PHP Errors:

[Wed Mar 02 17:03:18.718890 2016] [:error] [pid 2292] [client] PHP Fatal error: Uncaught exception 'ReflectionException' with message 'Class Magento\Framework\App\ResourceConnection\Proxy does not exist' in /var/www/html/vendor/magento/framework/Code/Reader/ClassReader.php:19\nStack trace:\n#0 /var/www/html/vendor/magento/framework/Code/Reader/ClassReader.php(19): ReflectionClass->__construct('Magento\\Framewo...')\n#1 /var/www/html/vendor/magento/framework/ObjectManager/Definition/Runtime.php(44): Magento\Framework\Code\Reader\ClassReader->getConstructor('Magento\\Framewo...')\n#2 /var/www/html/vendor/magento/framework/ObjectManager/Factory/Dynamic/Developer.php(71): Magento\Framework\ObjectManager\Definition\Runtime->getParameters('Magento\\Framewo...')\n#3 /var/www/html/vendor/magento/framework/ObjectManager/ObjectManager.php(71): Magento\Framework\ObjectManager\Factory\Dynamic\Developer->create('Magento\\Framewo...')\n#4 /var/www/html/vendor/magento/framework/ObjectManager/Factory/AbstractFactory.php(236): Magento\Framework\ObjectManager\ObjectManager->get('Magento\\Framewo...')\n#5 /var/ww in /var/www/html/vendor/magento/framework/Code/Reader/ClassReader.php on line 19

and this multiple times

[Wed Mar 02 17:03:18.718739 2016] [:error] [pid 2292] [client] PHP Warning: include(): Failed opening '/var/www/html/var/generation/Magento/Framework/App/ResourceConnection/Proxy.php' for inclusion (include_path='/var/www/html/var/generation:/var/www/html/lib/internal:/var/www/html/var/generation:/var/www/html/lib/internal:/var/www/html/vendor/phpseclib/phpseclib/phpseclib:/var/www/html/vendor/magento/zendframework1/library:/var/www/html/vendor/phpunit/php-file-iterator:/var/www/html/vendor/phpunit/phpunit:/var/www/html/vendor/symfony/yaml:.:/usr/share/php:/usr/share/pear') in /var/www/html/vendor/magento/framework/Code/Generator/Io.php on line 158


[Wed Mar 02 17:03:18.718377 2016] [:error] [pid 2292] [client] PHP Warning: include(): Failed opening '/var/www/html/var/generation/Magento//Framework/App/ResourceConnection/Proxy.php' for inclusion (include_path='/var/www/html/var/generation:/var/www/html/lib/internal:/var/www/html/var/generation:/var/www/html/lib/internal:/var/www/html/vendor/phpseclib/phpseclib/phpseclib:/var/www/html/vendor/magento/zendframework1/library:/var/www/html/vendor/phpunit/php-file-iterator:/var/www/html/vendor/phpunit/phpunit:/var/www/html/vendor/symfony/yaml:.:/usr/share/php:/usr/share/pear') in /var/www/html/vendor/composer/ClassLoader.php on line 412

Also, this is the core_config_data from the magento database

enter image description here

Any idea what i could try?

6 Answers 6

chown -R www-data:www-data /var/www/magento2/ 
chmod 777 -R var generated app/etc
rm -rf var/cache/* var/page_cache/* var/generation/*


php bin/magento setup:di:compile;

If you're using Docker, you need to restart the containers.

  • worked for me and i had missing other class that wasn't mentioned Commented Nov 11, 2019 at 0:51
  • 21
    chmod 777 is a very bad idea and allows others to hack your server easily especially on shared hosting! fix the users instead
    – Black
    Commented Jan 7, 2020 at 13:54

Delete composer autoload (vendor/autoload.php) as suggested by @JELLEJ and type composer install in magento root folder to recreate it.

It worked for me on Magento 2.3.5-p1 (but should work in other versions).

  • I tried all the other suggestions on this page and this was the only one that worked for me. Thanks! Commented Aug 6, 2020 at 17:36
  • didn't work for other versions Commented Aug 17, 2020 at 11:29
  • 2
    The accepted answer is true, but this one too depending on the situation. Worked for me. Commented Aug 25, 2020 at 9:22
  • 1
    worked for me! thx!
    – Alex B
    Commented Nov 17, 2020 at 17:58

several classes in Magento2 are generated dynamically. Except you are in Developer mode, this does not happen automatically.

To activate the developer Mode, you have to uncomment the Line in the beginning of your .htaccess file.

For production and default mode you have to execute the command bin/magento setup:di:compile from your magento root to generate the classes

  • After installing Magento2, and using the command setup:di:compile I still get the Server Error 500, and i noticed that i cannot show or set modes in magento using the deploy:mode:show and deploy:mode:set command.
    – Maarten
    Commented Mar 3, 2016 at 13:06
  • @Maarten, check your server logs
    – Black
    Commented Feb 19, 2020 at 15:48
  • Sometimes for me it helps to delete the vendor/autoload.php file
    – JJ15
    Commented May 18, 2020 at 8:50
  • 1
    @black, I don't say it is not needed. I say sometimes it helps removing it and doing the composer install again.
    – JJ15
    Commented Sep 28, 2020 at 13:46

Sharing below one-time steps ideally for the local setup, especially stand-alone Magento setups.

Commands mainly for Ubuntu-based.

  1. Use whoami command to find out which user is currently on. Mostly you will get non-root users.
someotheruser@core:/var/www/html$ whoami

Should output as below:

  1. Optional: Below one only requires if you are on non root Switch to non-root user(magento).
someotheruser@core:/var/www/html$ sudo -u magento /bin/bash
  1. Run below command to get the current user, should give magento as we have changed the user to magento
magento@core:/var/www/html$ echo "$USER"
  1. Give current user(magento) to www-data group as a secondary user
magento@core:/var/www/html$ sudo usermod -a -G www-data $USER
  1. Change ownership to directory
magento@core:/var/www/html$ sudo chown -R $USER:www-data /var/www/html/

Ownership can be given to the someotheruser user as well. Make sure to give to non-root users.

  • Worked well for me to resolve this error on various installations Magento 2.3.x to Magento 2.4.x.

  • This can resolve the above error if you are facing the same every time after running some bin/magento commands especially setup:upgrade or setup:di:compile


In case you are facing this issue whilst the permission set correctly already and mainly use RHEL/CentOS, you may be facing issues with files security context SElinux, as per the docs here, you may need to change the security context due to SElinux configuration on your root directory as following:


chcon -R --type httpd_sys_rw_content_t <magento_root>/app/etc


chcon -R --type httpd_sys_rw_content_t <magento_root>/var


chcon -R --type httpd_sys_rw_content_t <magento_root>/pub/media


chcon -R --type httpd_sys_rw_content_t <magento_root>/pub/static


chcon -R --type httpd_sys_rw_content_t <magento_root>/generated

This will make SElinux allow access from nginx/apache to your magento files.

  • First reason could be you have installed PHP 8 and Magento2 is not compatible with it yet. So to resolve this, you need to use PHP 7.4.
  • Other reason we need to find with below steps:
    • Open the bootstrap.php file present in the app folder of magento directory.
    • Remove # from the beginning of the line #ini_set(‘display_errors’, 1);
    • Save the file and refresh your browser to see the exact issue.

Happy Learning !! Thank You !!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.