1

I developed a Magento2 webshop with a custom theme and some extensions. Now suddenly, the checkout page shows weird behavior.

When I go to /checkout I see the spinner indicating that the Magento is building the checkout page. But, then I only see the email field and the coupon box. All other steps and fields are there, but they are hidden by the steps js I think.

The Payment step is directly shown instead of the billing address step.

enter image description here

Does anyone know what's going on here?

You can find the store here: goo.gl/QLG3AS (Dutch)

Update

The problem only seems to happen when (only) a configurable product is added to the cart, for example: goo.gl/gB30Bd. But if I add a simple product, for example: goo.gl/3vrCRX (alone, or with a configurable product) the checkout seem to work just fine.

6
  • Magento 2's checkout is significantly reworked and streamlined. Did you try entering your email address?
    – Ryan Hoerr
    Mar 2, 2016 at 13:54
  • Yes, I did. When I enter an email that has an account than the password field pop's up. I the email is unknown nothing happens and I cannot continue.
    – Silvan
    Mar 2, 2016 at 13:56
  • Have you checked browser console? It might show some JS failing to load, for example.
    – DmitryR
    Mar 4, 2016 at 10:59
  • Yes, I did. But, there's no error at all...
    – Silvan
    Mar 4, 2016 at 11:10
  • Have you tried disabling the modules and seeing if the issue still persists? Also, do any of the modules affect the checkout?
    – Ben Crook
    Mar 4, 2016 at 14:28

1 Answer 1

0

I was trying place order and successful do it. So, looks like problem in browser cache. Please try clean cache or do the checkout in incognito mode. Also please enable static file sign to do not have problem with cached content.

5
  • It occurs sometimes, I do have it right at this moment. Could you check again? I think you'll have the problem too.
    – Silvan
    Mar 11, 2016 at 16:55
  • I've updated my question, maybe you could point me in the right direction?
    – Silvan
    Mar 14, 2016 at 16:33
  • Can you verify, maybe product assigned to configurable have virtual type?
    – KAndy
    Mar 14, 2016 at 17:54
  • The products assigned to the configurable product do have virtual type. Is this wrong?
    – Silvan
    Mar 14, 2016 at 18:20
  • It's normal. But in this scenario where product is not shippable the first step where user enter shipping information will be skipped.
    – KAndy
    Mar 14, 2016 at 19:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.