1

I have a problem like in attachment. I don't know why address isn't rendering. Please help me how to debug this.

enter image description here

  • Does it happen when you switch back to the native default/default Magento template ? – Raphael at Digital Pianism Mar 1 '16 at 8:36
  • This is Magento blank theme template. It happend right after instalation. – MaQ Mar 1 '16 at 9:09
  • Which Magento version ? No extension installed ? – Raphael at Digital Pianism Mar 1 '16 at 9:10
  • Magento 2.0.2 CE. No extensions. Clean installation. This is test enviroment CentOS (nginx, php5.6.9). What is interesting, I have installed Magento on local enviroment and everything works Ubuntu (nginx, php5.6.18). Any ideas? – MaQ Mar 1 '16 at 9:14
2

The issue is caused by inability to load address attributes from EAV tables in the database. Magento assumes values of certain IDs invariant and thus they're hard-coded in a PHP code for performance optimization purposes. Attribute set ID = 2 is hard-coded for address attributes. However, the field eav_attribute_set.attribute_set_id is AUTO_INCREMENT and thus is governed by MySQL settings auto_increment_increment and auto_increment_offset. Having non-default values for those settings is the root cause of the issue.

The fix:

  1. Make changes to the MySQL config my.cnf:
    • auto_increment_increment = 1
    • auto_increment_offset = 1
  2. Restart MySQL to apply the config changes
  3. Create a new empty database
  4. Re-install Magento from scratch to the new database

Note: Changing MySQL settings above will not recover the existing database.

  • You might have right. This server is working on Percona cluster. Rows multiply every 3 (for example 1,4,7). Thanks for the clarification. You're great. – MaQ May 16 '16 at 7:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.