0

i am trying to import Magento database in PHPMYADMIN. I have exported the database using the PHPMYADMIN. I am receiving this error message when i try to import the magento database. How should i fix this error. any help will be greatly appreciated. thanks

MySQL said: Documentation #1146 - Table 'magento_oldagain.adminnotification_inbox' doesn't exist

INSERT INTO `adminnotification_inbox` (`notification_id`, `severity`, `date_added`, `title`, `description`, `url`, `is_read`, `is_remove`) VALUES
(1, 4, '2008-07-24 23:54:40', 'Magento 1.1 Production Version Now Available', 'We are thrilled to announce the availability of the production release of Magento 1.1. Read more about the release in the Magento Blog.', 'link is here', 0, 0),
(2, 4, '2008-08-02 00:00:16', 'Updated iPhone Theme is now available', 'Updated iPhone theme for Magento 1.1 is now available on Magento Connect and for upgrade through your Magento Connect Manager.', 'link is here', 0, 0),
(3, 3, '2008-08-02 00:10:27', 'Magento version 1.1.2 is now available', 'Magento version 1.1.2 is now available for download and upgrade.', 'link is here', 0, 0),
(4, 3, '2008-08-1[...]

enter image description here

  • Is the adminnotification_inbox table present in your database ? – Raphael at Digital Pianism Feb 29 '16 at 10:04
  • Yes it exist in the table from which i have exported database – Paramveer Kumar Feb 29 '16 at 10:07
  • Please ensure that your table is getting created in your script before the lines you pasted ? – Raphael at Digital Pianism Feb 29 '16 at 10:08
  • Hello, Phpmyadmin only exporting insert command not the create table command what should i do. How can i show you images of my current problem. i am only seeing insert sql command in exported table file. Please help! – Paramveer Kumar Feb 29 '16 at 10:15
  • In process of export, you have the option to export table structure as well as data. Make sure you are using that. – Prateek Feb 29 '16 at 10:52
0

First of all try to export your database using mysqldump console utility:

mysqldump -u root -p --compress --disable-keys --quick DATABASE_NAME > /your/path/database_dump.sql

Then import your database using mysql command:

mysql -u root -p YOUR_NEW_DB_NAME < /your/path/database_dump.sql

Note: Please change your root with your database username.

Hope this will fix your problem.

  • Oh my god, it is working after exporting and importing sql database file using the command prompt. Many many thanks to you sir. it solved my problem. I have wasted all my day today figuring out this issue. lastly i tried your suggested steps. – Paramveer Kumar Feb 29 '16 at 14:21
  • Great, happy coding .... :) – Jayesh Patel Feb 29 '16 at 16:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.