0

folks,

I am working on Ubuntu 14 and I followed this short video to install Magento2. I've also used some installation guidelines from Magento website.
I've passed the readiness check successfully and I have completed the installation also successfully with no errors or even one warning.

Now the problems that I'm facing:

  • When I try to open http://127.0.0.1 this opens a broken, not organized, not aligned, and not formatted page. I did a search on the net and I found that it is a problem related to something called CSS, which I don't know what it is and how to fix.
  • If I try to open 127.0.0.1/admin (and I'm sure that the link is correct) I get that 404 Not Found page!

For god sake help :( ... I've been working on fixing this for a week! But Please use simple words and detailed steps; as I'm not deep in IT things ... when you suggest a solution please tell me exactly how to do it ... when you want me to change something in any file or any configuration, please tell me where it is exactly or how to find it.

thanks in advance

  • Follow this solution. magento.stackexchange.com/questions/97209/… – sandip Feb 29 '16 at 10:59
  • OK now I have manged to solve the admin page part and it is now opening, and that is by adding the following to the 000-default.conf file ..... <Directory /var/www/magento2> Options Indexes FollowSymLinks MultiViews AllowOverride All Require all granted </Directory> ............. but still the page formatting and the CSS problem is there! – Whaaaaat Feb 29 '16 at 12:09
0

I think you have url rewrite issue

Go to Database in "core_config_data" table there is "web/seo/use_rewrites" set it to 0.

after that clear cache:

bin/magento cache:flush

reindex all:

php bin/magento indexer:reindex
  • I've tried your suggestion, then restarted apache, but it did NOT solve any of the issues .... so I retruned "web/seo/use_rewrites" to 1 – Whaaaaat Feb 29 '16 at 10:28
0

I am newbie i had similar issue . Was able to resolve this issue by below steps.

php bin/magento setup:upgrade php bin/magento setup:static-content:deploy Or php bin/magento setup:static-content:deploy -f Update apache.conf Options Indexes FollowSymLinks AllowOverride none Require all granted with Options Indexes FollowSymLinks AllowOverride All Require all granted Restart apache server Replace the .htaccess file Delete pub/static/* Except .htaccess files Delete var/generation/* var/cache/* var/page_cache/* var/view_preprocessed/* var/composer_home/cache/*

Download the htaccess files from below link http://lovetomarry.com/packages/Magento.zip

0

Copy .htaccess from your magento pub directory and paste in root directory for 404 error.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.