0

I have installed a "fresh old" Magento (v1.7.2) for testing purposes and I have created two different stores with different store views:

store setup

If I take a look at the frontend of my shop I can see that the store switcher is enabled:

store switcher

Furthermore I have created a global category "electronics" and I have configured the name and url key for the german store view. So this category is enabled for both stores. In addition I have created the sub directory "gb" in my Magento root directory. This directory represents the english store, so I have created some symlinks and a htaccess file which sets the store code:

SetEnv MAGE_RUN_CODE gb

So far all is working fine and I got two different stores with the following urls:

So the category urls for my global category electronics looks as follows:

But If I change the store on the german electronics category page to the english store I get redirected to home page of the english store and not to the english category page of electronics. So I have inspected the store switcher on the german electronics category page:

<div class="store-switcher">
    <label for="select-store">Select Store:</label>
    <select id="select-store" title="Select Store" onchange="location.href=this.value">
          <option value="http://localhost/magento-1.7.2/gb/?___store=gb">English Store</option>
          <option value="" selected="selected">German Store</option>
    </select>
</div>

As you can see the values of the store switcher seems to be wrong because I have expected something like the following:

<div class="store-switcher">
    <label for="select-store">Select Store:</label>
    <select id="select-store" title="Select Store" onchange="location.href=this.value">
        <option value="http://localhost/magento-1.7.2/gb/electronics.html">English Store</option>
        <option value="http://localhost/magento-1.7.2/elektronik.html" selected="selected">German Store</option>
    </select>
</div>

But I don't know why the store switcher is not working as expected. Did I forget a specific setting?

UPDATE

Or is this just a configuration mistake because this is not a multistore case and I have to use store views instead of multistores, because multistores are independent of each other?

0

Using store views instead of stores works for me. So the language switcher will be activated and not the store switcher.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.