0

I upgraded my Magento 1.4 to Magento 1.9.2.2. Upgrade completed successfully but after upgrading, admin panel is too slow. Sometimes, up to 1.3 minutes.

I enabled Magento profiler. Most time consuming calls were these:

Code Profiler                                   Time     Cnt Emalloc   RealMem
mage                                            33.0621  1   0         0
mage::dispatch::routers_match                   32.9778  1   0         0
mage::dispatch::controller::action::predispatch 25.1045  1   9,281,168 9,175,040
DISPATCH EVENT:controller_action_predispatch    25.0586  1   3,260,744 2,621,440

I read some articles about speeding up Magento admin panel. Enabling cache and disabling extensions are done. When I disabled extensions, the speed significantly grow. But disabling them one by one didn't make any difference.

What should I do to find the bottleneck(s)?

1

1.4 to 1.9 is a big jump, you are probably simply going out of computational resource and you need a better hosting.

If you want to make more tests on disabling extensions just make sure you are turning them off by modifying the xml files in app/etc/modules. JUst open the extension you wish to disable and set <active> tag to false. Manually flush the cache at each step by removing the content of var/cache directory (do NOT remove the cache folder itself).

If you get errors after disabling a module just turn it back on to fix.

Disabling from backend only disables their output, but they remain active.

Also check your cache engine, using Redis may result a in good performance boost.

For frontend you can use MSP LTS2 Full-Page Cache module: https://github.com/magespecialist/lts2

If you already did this, please make a better profiling with AOE_Profiler: https://github.com/AOEpeople/Aoe_Profiler

  • Thanks for reply. I have no problem in frontend. Also I disabled extensions by modifying app/etc/modules. Cache cleared manually from both var/cache and /tmp/magento/var/cache. I have another Magento installation on this server as well with no problem. – Pedram Behroozi Feb 23 '16 at 22:55
  • Use AOE_Profiler to profile in a better way your store: github.com/AOEpeople/Aoe_Profiler . The info you gave are not enough to guess what is wrong. – Phoenix128_RiccardoT Feb 23 '16 at 23:01
  • The extension was brilliant! I've found that two extensions were checking for notifications and updates from their external web services. I disabled them and everything's looks fine now. Thanks. – Pedram Behroozi Feb 23 '16 at 23:25
  • AOE_Profiler saved my life a lot of time ;) – Phoenix128_RiccardoT Feb 23 '16 at 23:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.