0

I've inherited this site from someone else. I had to install it into a sub-directory on a go daddy server. Not sure where it came from. We have a customer registration form with a captcha that is not showing the .png file. I have set the permissions to all folders that go to that file to 777. When I view source code the path is correct and there is an image in that folder that was just created, but when I copy and paste the url path to the captcha image in the browser I receive a 500 internal server error.

Here's the form

http://wheybetterguard.com/wheybetterguard/shop/index.php/customer/account/create/

So I can see in the directory that the captcha image is created on page load example: http://wheybetterguard.com/wheybetterguard/shop/media/captcha/base/969f1d56057653feab9e8d392a11efd2.png

Everything seems to be working correctly except that the image is breaking for some reason.

Please help.

15
  • I get a 500 error page when opening the captcha URL Feb 23, 2016 at 21:07
  • @RiccardoT That's what I'm trying to figure out. There's an image there that I can download from the server and see the captcha code, but when it's on the site I can't visually see it through that URL, nor does the site. Feb 23, 2016 at 22:14
  • I think it is a webserver issue, can you paste your server error.log? Feb 23, 2016 at 22:18
  • Maybe a wrong URL rewrite Feb 23, 2016 at 22:19
  • @RiccardoT I just started the error log. Won't be available until March 1st. Is there another way to get you that information? Feb 23, 2016 at 22:37

2 Answers 2

1

I'm not 100% sure, but you may have some wrong htaccess directive inside

/wheybetterguard/shop/media/captcha/base

or inside

/wheybetterguard/shop/media/captcha

Try also by checking if you enabled the RewriteBase directive in you main .htaccess file.

I'm pretty sure it is an htaccess misconfiguration.

Also try temporarly removing the .htaccess file from /wheybetterguard/shop/media.

If it works you have some kind of issue with that htaccess file or with get.php file we should investigate on your errors.log.

That file is mainly used to permit the DB images and to give you a minumum discovery protection.

In case replace it with:

Options All -Indexes

It will give you a basic path discovery protection.

1
  • The problem was the /media/ .htaccess file. Further details will come from errors.log Feb 24, 2016 at 7:35
0

I found a solution, this may work for others.

  • Check Folder permission.
  • Mine was set to "Root Root"
  • I changed that to "www-data www-data"

And it worked fine for me.

Captcha folder permission

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.