1

Tried to update to SUPEE-7405 Magento patch with 1.9.1.0 using the .zip package as I'm on shared hosting with no SSH access.

Uploaded all the files successfully with FTP and came across 2 erros (maybe more??)

First on the Admin Backend;

Fatal error: Class 'Mage_Core_Helper_UnserializeArray' not found in /home/pctekcom/public_html/app/Mage.php on line 547

Second on the Frontend Home Page;

Fatal error: Call to a member function isTypeAllowed() on boolean in /home/pctekcom/public_html/app/code/core/Mage/Core/Model/Email/Template/Filter.php on line 177

I've tried two different instances and the same errors occur I'm using PHP 5.6.18 as shown @

pc-tek.com.au/test.php

Anyone got a working Magento 1.9.1.0 with SUPEE-7405?

Thanks, Steve

3

You are missing other patches that SUPEE-7405 depends on being in place so it can be applied.

If you are going to use this method, download all the zip packages for all the patches needed for 1.9.1.0 and apply them. SUPEE-1533 THROUGH SUPEE-7405

Since this method of applying patches does not append the change list to app/etc/applied.patches.list and you didn't keep track by creating your own change file to track applied patches, you do not know what's been applied and you will have these errors popping up until you get them all installed.

The patch chain you need to make sure has been applied is as follows in the list order: SUPEE-1533, SUPEE-5344, SUPEE-5994, SUPEE-6285, SUPEE-6482, SUPEE-6788, SUPEE-7405

You are missing at least SUPEE-6788

  • Thanks a bunch dude! Can't believe I didn't think of this... silly silly. – SixShields Feb 23 '16 at 3:27
  • Welcome to tracking changes. Make a file called change.log in app/etc/ and list the patches you have applied through the download method. Add new ones as they come out and then you'll know if you missed any. You're welcome! – Fiasco Labs Feb 23 '16 at 3:29
  • Yeah I've got my big book of Magento F**K ups and have written them down accordingly. – SixShields Feb 23 '16 at 3:36
  • <sigh> Yeah, the endless software/firmware bugs. Just got a week of my life eaten by Cisco ASA IKEv1/v2 issues. Every time I think I'm getting ahead, there's always another security patch like Linux glibc6 dns resolving. Yegad! when will it ever end? – Fiasco Labs Feb 23 '16 at 3:58
  • I'm hoping never, alot of you guys would be out of a job ;) – SixShields Feb 23 '16 at 4:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.