0

What version of php is recommended with magento 1.9.1.1?

I was running PHP 5.3.29, and ran into problem of Sales>Orders>Order View Information were not getting displayed in admin after the latest SUPEE-7405! So I upgraded the PHP version to 5.4.45, and it started to display Sales>Orders>Order View Information again.

My cPanel has 5.5.32 and 5.6.18 also available. Is it recommended to upgrade to any of them or not?

1

The answer is yes. The difference between 5.3 and 5.6 (and also between 5.4 and 5.6), from the performance point of view is significant and PHP 5.6 is stable enough to relay on.

The upgrade is safe for Magento, Magento is declared to work with 5.6.x. You should not see any problem. If you can do it safely you are encourgaed to do it.

Of course you will also have security and stability benefits with a newer version.

Anyway, AFAIK 5.5 should be the recommended one for Magento 1.9. Upgrading do 5.6 is up to you and it should work without problems.

  • Is it recommended to upgrade it to 5.6.x? – user2774042 Feb 22 '16 at 20:47
  • 1
    As far as I know 5.5 is the recommended one with 1.9.x, but 5.6 should work as well with some minor improvement. – Phoenix128_RiccardoT Feb 22 '16 at 21:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.