0

I'm really sorry about this but I'm at a loose end with no one able to help. I'm also a bit of a newbie so bear with me.

I've recently moved web hosts, since then my Magento site is not sending out emails.

I'm using the SMTP Pro extension with an email address managed by google apps. Not sure if it's relevant but my domain name is managed by Fasthosts & I have the Google MX records in there (Unchanged since server move) and an SPF record (unchanged)

My new web host has not set up any domain records etc in cpanel (and I don't know how to do it) they're going to do this but are not convinced it will help the issue as they do not manage the domain.

The error I'm receiving is as follows:

SMTP Pro Self Test Results Sending test email to your contact form address: admin@motif8.co.uk from: noreply@motif8.co.uk. Unable to send test email. Exception message was: Incorrect authentication data Please check the user guide for frequent error messages and their solutions. Default templates exist. Email communications are enabled. Required database tables exist.

I've tried a PHP script and it sent a test email without any issues, Magento permissions are all set as should be.

Before I moved host, my email settings within magento were 'localhost' on port 25, I've tried all manner of ports, all smtp.gmail.com variants and many different email addresses & passwords within our company (and some throwaway gmail accounts) to no avail.

Really hoping for some suggestions as I'm at a complete loss! Thanks!

2

Assuming that SMTP Pro is configure correctly and you hosting company is not blocking that port.

Log into your gmail account and follow the steps below.

Change your settings to allow less secure apps to access your account. We don't recommend this option because it might make it easier for someone to break into your account. If you want to allow access anyway, follow these

steps:

  • Go to the "Less secure apps" section in My Account.

  • Next to "Access for less secure apps," select Turn on. (Note to Google Apps users: This setting is hidden if your administrator has locked less secure app account access.)

Reference : https://support.google.com/accounts/answer/6010255?hl=en

  • I am testing on Localhost using SMTP Pro, testing mail working, but localhost order mail not working. How to make send new order mail in localhost. – zus Jan 10 '18 at 7:58
  • You will need to debug to figure out why it is not working – Renon Stewart Jan 10 '18 at 15:09
  • I tried all from my knowledge,, my live site is working,, but in localhost not working,, but test mail working.. – zus Jan 11 '18 at 3:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.