0

I have setup 3 magento websites, one for EN, AU and US. I did it as seperate websites as I want to change the price to a fixed price for each currency.

I have setup the three different currencies and change the price for each store against each product.

The price does change depending on the store, but the currency symbol never changes.

Can anything think of any reason this might be?

1

Probably a template issue, make sure your template is using formatPrice method from core helper.

E.g.:

<?php $_coreHelper = $this->helper('core'); ?>
...
<?php echo $_coreHelper->formatPrice($_finalPrice, false) ?>
...

Start checking from catalog/product/price.phtml. Try also copying it from base/default to see if the issue is there.

Also try switching to default template to make a test and see if it fix (the problem can be somewhere else in your template).

  • Hey, thanks very much for the reply. It seems to be using formatPrice everywhere, and even if I change it to the default template it still has the same problem. Can you think of anything else? I'm guessing it must be a config setting I have missed – user989952 Feb 22 '16 at 0:30
  • The only setting I can guess is the currency symbol itself in the backend config. Did you double check it? – Phoenix128_RiccardoT Feb 22 '16 at 0:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.