1

I get some issue my custom theme and it's get from one of extension jquery version. How can I fix this issue ?

extension .xml file;

<layout>
<default>
    <reference name="head">
         <action method="addItem"><type>skin_js</type><name>js/iyzicoonpagecheckoutform/jquery-1.7.1.min.js</name><params/></action>
        <block type="core/text" name="google.cdn.jquery">
            <action method="setText">
                <text>
                    <![CDATA[
                        <script type="text/javascript">izQuery = jQuery.noConflict(true);</script>
                    ]]>
                </text>
            </action>
        </block>

And local.xml file in my custom theme ;

<default>
    <reference name="head">
        <!--input js-->
        <action method="addJs"><script>smartwave/jquery/jquery-1.11.2.min.js</script></action>
        <action method="addJs"><script>smartwave/jquery/jquery-migrate-1.0.0.js</script></action>

I don't have any issue my custom theme version , everything get about extension jquery version.But I don't know how to fix is ?

0

Initially I'd recommend do not break any values in XML file

            <text><![CDATA[<script type="text/javascript">izQuery = jQuery.noConflict(true);</script>]]></text>

Make your code more obvious. For that purpose better put noConflict function into separate file. And include it as you included jQuery lib.

In conclusion there are much more possible answers. Better show us which error did you face.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.