I have recently encountered a very strange situation on the catalog price rules. I am using Magento and have applied a 15% off discount for all products since 1 Jan 2016 and it has been fine. Suddenly three days ago, the discount simply "disappeared" after midnight. And then at around 00:59am, the system notified that the cache of the Blocks HTML Output was invalidated and right after refreshing it, the discount rule works again. (It seems that there is a gap in-between.)

I didn't install any extension in February. The cron, I believe, works fine. I have tried to reapply the discount rule but the problem remains.

I have tried the solution provided by Alexei Yerofeyev (see https://stackoverflow.com/questions/25280095/magento-catalog-price-rule-disappears-at-night). The problem seems to be solved but it re-occured the next mid-night. I have also tried the solution provided by this post (Catalog price rule from today does not apply). The problem remains.

The timezone of my store is GMT (I am not sure about the server time, probably US time...).

I suspect it is a cron problem but I am not sure. Any idea how to fix it? I would be very grateful if this can be fixed!! Thank you very much! (Apology for the ghost-story-like title...)

P.S. Just saw Marius's solution (Catalog price rule stops at midnight). Hope it works!

UPDATE: I have followed @Bernhard Prange suggestion and installed AOE Scheduler. catalogrule_apply_all and catalog_product_index_price_reindex_all (and others) are shown as "ENABLED" in Available Jobs section. But it is rather strange that both jobs cannot be found in either List or Timeline View (not even under "PENDING"). Is it because the "Cron Expression" of catalogrule_apply_all is 0 1 * * *? Thanks!!

1 Answer 1

  1. Have a look what crons are running at the given time. Use AOE Scheduler for this.
  2. Move those crons out of the date change zone between your server time zone and the magento timezone.
  3. maybe have the caches cleared directly after price rule application?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.