There has been an error processing your request Exception printing is disabled by default for security reasons. error ... what problem ?

a:5:{i:0;s:67:"Illegal scheme supplied, only alphanumeric characters are permitted";i:1;s:711:"#0 /home2/letmicro/public_html/app/code/core/Mage/Core/Model/Store.php(777): Zend_Uri::factory('www.letmicrowav...')
#1 /home2/letmicro/public_html/app/code/core/Mage/Core/Controller/Varien/Front.php(332): Mage_Core_Model_Store->isCurrentlySecure()
#2 /home2/letmicro/public_html/app/code/core/Mage/Core/Controller/Varien/Front.php(161): Mage_Core_Controller_Varien_Front->_checkBaseUrl(Object(Mage_Core_Controller_Request_Http))
#3 /home2/letmicro/public_html/app/code/core/Mage/Core/Model/App.php(354): Mage_Core_Controller_Varien_Front->dispatch()
#4 /home2/letmicro/public_html/app/Mage.php(684): Mage_Core_Model_App->run(Array)
#5 /home2/letmicro/public_html/index.php(87): Mage::run('', 'store')
#6 {main}";s:3:"url";s:121:"/www.letmicrowave.comindex.php/admin/dashboard/index/key/b93f7fcf9aa264fefeca8b933fa2b0a8/?SID=j5ei41mqapto3obhasn1rqf2u0";s:11:"script_name";s:10:"/index.php";s:4:"skin";s:7:"default";}

1 Answer 1


NOTE: If you have changed the admin url by using the admin backend and lost access, use the steps here to regain access.

How to properly change the Admin Base URL so you don't have to follow the above link.

Never use the System=>Config=>Advanced=>Admin=>Admin Base URL settings to do this. It usually ends up in site fubar.

Every local.xml has the fix sitting right there staring us in the face. Find this section:


Save a copy to your local workstation so you can recover if you mess up and then change this line as follows giving somethingelse your own particular branding:


Then refresh Magento cache by one of two methods so Magento re-reads the configuration to include your change.

  1. Go into backend System=>Cache Management and click the Flush Magento Cache button.

  2. Manually, using your SCP/SFTP client, log into the Magento file system, find the var/cache/ directory and delete all the cache--? subdirectories (question mark stands for the 0 through f increment number at the end)

Why it's not a good idea to use the System=>Config=>Advanced=>Admin=>Admin Base URL settings area to do this, unless A) you understand their function, B) you understand how to recover if you make the wrong choice.

  1. If you mess up, you lose ability to log into the Admin Panel Backend and will need to mess around with 3-5 rows in the core_config_data to get back in. It's easier to use the old, reliable method of just editing a text file.

  2. Naming conventions in the Admin Base URL section have always been arcane and one of them is not for common use as it's for Node Clustering where the Admin backend may be running on a sub-domain, not the internet facing public web server. Setting this one Use Custom Admin URL, removes access to your Admin Backend.

  3. If you're proficient with phpMyAdmin or MySQL commands and aren't worried by tracing down what's necessary to get the admin backend accessible again, below is the proper setting to change the Use Custom Admin Path setting as depicted.

you now should be able to access the Admin backend with the new route path you entered.

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.