3

Hello I'm using the latest magento source files from magento website. I've installed the files via directions on the support documentation of magento website and at the Readiness Check point i get the follwing errors:

our PHP Version is 5.6.14, but always_populate_raw_post_data = 0. $HTTP_RAW_POST_DATA is deprecated from PHP 5.6 onwards and will be removed in PHP 7.0. This will stop the installer from running. Please open your php.ini file and set always_populate_raw_post_data to -1. If you need more help please call your hosting provider.

all other php checks are correct. Rediness Check Results

When I begin to debug the error with trying to find the php.ini file. I have:

  1. Created the phpinfo.php page to determine where the php.ini file is located.

    I get this information location of php.ini file

2. I CANNOT FIND THE PATH FOR /opt/php56/lib/php.ini

1

edit php.ini

find
always_populate_raw_post_data = On

change to
always_populate_raw_post_data = -1

close web page.. restart xampp or wamp

  • these files are on the server an im accessing via cpanel/ ftp and cannot find the file to edit or find the php.ini file. – simpleWebGuy Feb 16 '16 at 2:30
  • Check where your ini file is loaded, its path by hitting the url of the server root – Sushivam Jul 5 '16 at 11:42
1
  1. Open the .htaccess file inside your magento root

  2. Find the line <IfModule mod_php5.c> and add the lines below before </IfModule>

The point is the following lines should be between

<IfModule mod_php5.c> and </IfModule>
  1. Insert these lines below in your .htaccess file and save the file and proceed with your installation.

     #########################################
     ## Turn off automatically populating $HTTP_RAW_POST_DATA
    
     php_flag always_populate_raw_post_data off
    

If the above lines didnt work then try -1 instead of off

     ###########################################
     ## Turn off automatically populating $HTTP_RAW_POST_DATA

     php_flag always_populate_raw_post_data -1

Please note, i assumed you use php5.x without FastCGI , incase of FAST CGI follow this article

1

We created a new php.ini file on the root of server and edited the always_populate_raw_post_data -1 and now we can proceed further. THanks for the feedback and answers they did help me achieve the goal.

see our image below enter image description here

0

Search in php.ini and remove ; from php_flag always_populate_raw_post_data -1

Restart server it will work :)

Not the answer you're looking for? Browse other questions tagged or ask your own question.