1

In a fresh install of Magento Community Edition 1.9.2.2, if I try to hit a 404 page (wrong url) I get a Magento Exception, instead of the regular CMS No Route page.

enter image description here

Example URL: https://www.example.com/wrong-url

Report:

a:5:{i:0;s:52:"Front controller reached 100 router match iterations";i:1;s:456:"#0 /var/www/vhosts/example.com/app/code/core/Mage/Core/Controller/Varien/Front.php(179): Mage::throwException('Front controlle...')
#1 /var/www/vhosts/example.com/app/code/core/Mage/Core/Model/App.php(365): Mage_Core_Controller_Varien_Front->dispatch()
#2 /var/www/vhosts/example.com/app/Mage.php(684): Mage_Core_Model_App->run(Array)
#3 /var/www/vhosts/example.com/index.php(83): Mage::run('default', 'store')
#4 {main}";s:3:"url";s:10:"/wrong-url";s:11:"script_name";s:10:"/index.php";s:4:"skin";s:7:"default";}

In the Magento dashboard > System > Configuration > Web > Default pages, the CMS No Route Page is set to an existing page.

The Mage_Cms module is enabled.

No exceptions are logged in exception.log

We use nginx + php-fpm.

I already checked What is the cause of "Front controller reached 100 router match iterations" error? and the information in https://github.com/convenient/magento-ce-ee-config-corruption-bug#update-2-further-improvements.

  • any custom extension extension is creating issue and you need to fix it – Amit Bera Feb 16 '16 at 1:24
  • it's a fresh install – J Plana Feb 16 '16 at 17:16
3

After some time debugging Mage_Core_Controller_Varien_Front, it showed up that it was trying to load a wrong no_route path.

I run the next query:

SELECT * FROM core_config_data where path = 'web/default/no_route';

and I could confirm the value set there was wrong, so I updated to be:

cms/index/noRoute

and everything started working just fine.

References: http://magentoexplorer.com/how-to-debug-and-fix-front-controller-reached-100-router-match-iterations-in-magento

  • I've encountered the same error, and it appeared that clearing the cache resolved it. But thanks for the tip to look for no_route in my database. – MarkE Sep 12 '17 at 22:33
0

Check the Magento configuration settings Default No-route URL at

System > Configurations > Web > Default Pages
. It should be set the default value cms/index/noRoute. Check the particular store value as well whether it default value has been overwritten here. Magento can go into an infinite loop till it hits the 100 iterations limit if it is not set properly.

I have found the solution here, this is was the issue in my case. You can check the URL for other options.

https://merchantprotocol.com/506/solved-front-controller-reached-100-router-match-iterations/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.