0

I've been having a hard time getting my cronjobs working for my new magento 1.9.2.3 install. I added a mailto along with my cron call in crontab and i've been getting back error messages like this:

PHP:  syntax error, unexpected '(' in /usr/local/lib/php.ini on line 3
X-Powered-By: PHP/5.5.31
Content-type: text/html


Fatal error: Uncaught exception 'Zend_Db_Adapter_Exception' with message 'The PDO extension is required for this adapter but the extension is not loaded' in /home/kegel4/public_html/lib/Zend/Db/Adapter/Pdo/Abstract.php:344 Stack trace: #0 /home/kegel4/public_html/lib/Zend/Db/Adapter/Abstract.php(248): Zend_Db_Adapter_Pdo_Abstract->setFetchMode(2) #1 /home/kegel4/public_html/app/code/core/Mage/Core/Model/Resource.php(175): Zend_Db_Adapter_Abstract->__construct(Array) #2 /home/kegel4/public_html/app/code/core/Mage/Core/Model/Resource.php(110): Mage_Core_Model_Resource->_newConnection('pdo_mysql', Object(Mage_Core_Model_Config_Element)) #3 /home/kegel4/public_html/app/code/core/Mage/Core/Model/Resource/Db/Abstract.php(320): Mage_Core_Model_Resource->getConnection('core_write') #4 /home/kegel4/public_html/app/code/core/Mage/Core/Model/Resource/Db/Abstract.php(350): Mage_Core_Model_Resource_Db_Abstract->_getConnection('write') #5 /home/kegel4/public_html/app/code/core/Mage/Core/Model/Resource/Db/Abstract.php(335): Mage_Core_Mo in /home/kegel4/public_html/lib/Zend/Db/Adapter/Pdo/Abstract.php on line 344
  • UPDATE: added php.ini calling the PBO to lib folder and now I'm only getting this error... PHP: syntax error, unexpected '(' in /usr/local/lib/php.ini on line 3 X-Powered-By: PHP/5.5.31 Content-type: text/html <br /> <b>Warning</b>: require_once(/abstract.php): failed to open stream: No such file or directory in <b>/home/kegel4/public_html/shell/scheduler.php</b> on line <b>3</b><br /> <br /> <b>Fatal error</b>: require_once(): Failed opening required '/abstract.php' (include_path='.:/usr/local/lib/php') in <b>/home/kegel4/public_html/shell/scheduler.php</b> on line <b>3</b><br /> – The_Dsigner Feb 12 '16 at 19:24
0

The error is clear

PHP:  syntax error, unexpected '(' in /usr/local/lib/php.ini on line 3

Paste that file /usr/local/lib/php.ini here, so people can tell you how to fix that syntax error

  • I found this: ini_set('MAX_EXECUTION_TIME', -1); – The_Dsigner Feb 15 '16 at 19:43
  • Is this all the content of the file? If so, just delete that file (or rename it). Or, if you want to keep that config, change that line for max_execution_time = -1 – Raul Sanchez Feb 16 '16 at 7:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.