0

I have followed the answer in this question however when I test my results are coming back the the extensions are still enabled

I have created a file in app/etc/modules called zzz_Disabled_Modules.xml

<?xml version="1.0"?>
    <config>
        <modules>
            <Mage_Downloadable>
                <active>false</active>
            </Mage_Downloadable>
            <Mage_Authorizenet>
                <active>false</active>
            </Mage_Authorizenet>
            <Mage_Rss>
                <active>false</active>
            </Mage_Rss>
            <Mage_Poll>
                <active>false</active>
            </Mage_Poll>
            <Phoenix_Moneybookers>
                <active>false</active>
            </Phoenix_Moneybookers>
            <Mage_Bundle>
                <active>false</active>
            </Mage_Bundle>
            <Mage_Rating>
                <active>false</active>
            </Mage_Rating>
            <Mage_Tag>
                <active>false</active>
            </Mage_Tag>
            <Mage_Captcha>
                <active>false</active>
            </Mage_Captcha>
        </modules>
    </config>

I then have a file in my doc root called test.php

include('app/Mage.php');
Mage::app()->setCurrentStore(Mage_Core_Model_App::ADMIN_STORE_ID);
error_reporting(E_ALL | E_STRICT);
Mage::setIsDeveloperMode(true);
ini_set('display_errors', 1);

zend_debug::dump(Mage::helper('core')->isModuleEnabled('Mage_Poll'));
exit;

The result that comes back for all modules is bool(true)

0

Use a capital "Z" for the file name: ZZZ_Disabled_Modules.xml and don't forget to clean the config cache.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.