1

This is the problem.

Live site blank in frontend or keep on loading and never load

impossible solution is we have to tell to customers that please clear your browser cache and than browse our site.

We need some Permanent solution for this.

please someone help us.

4
  • 1
    Why did you open a new question? Why is the bounty not on the original question? My guess is there might be something wrong with the core, did you try to update the store to a newer version so you are sure the Magento core is ok? After that you can look further when needed, but a core problem would be ruled out. – Akif Feb 17 '16 at 16:18
  • i tried to create bounty on new question, i should award minimum 300 points, so i created bounty and linked for that. we will try to upgrade to newer version. – Baby in Magento Feb 17 '16 at 16:51
  • @BabyinMagento instead of wasting days, take fresh copy of magento and install one by one module. if every thing get succeed import the customers, products and orders data. which takes time but its better when we don't have solution – prasad maganti Feb 19 '16 at 14:02
  • @prasadmaganti thanks a lot for tips. but client want solution.to fix the issue. – Baby in Magento Feb 20 '16 at 14:33
5

As I can see in Chrome Cookies, Magento sets two cookies: one for domain ".sitename.com" and another for "sitename.com" with same name "frontend". After some time cookie with domain "sitename.com" will be expired because Magento does not use it anymore after creation. On all next pages Magento update the cookie with domain ".sitename.com". Probably after expiring you get conflict and it doesn't send any cookie to Magento. I would recommend you to set Cookie options for your domain like:

Cookie Path: / Cookie Domain: sitename.com

And check if it still creates two cookies. Also check with domain .sitename.com

7
2
+50

Other than the suggestion I gave you in the other post (the hacked website possibility) you can also check your core_sessions MySQL table size.

Also check you are not using disk session with a huge session amount.

Make a test changing your local.xml:

<session_save><![CDATA[files]]></session_save>

Change to:

<session_save><![CDATA[db]]></session_save>

After this flush your cache and see if the problem persists.

8
1

Magento has in-built feature of setting the cookies lifetime to any number of seconds.

For turning this feature on go to Admin >> Session Cookie Management >> Lifetime and give a lower value(3600 or lower than that) and "Save" the system-config.

Hope this works for you

2
1

Several reasons why this could happen.

This happens when a module is trying to initialize a session, before sessions have started, so you may need to debug to find which module is doing that.

The other thing that can help is to set the cookie domain in your configuration as .sitename.com and set path to / This is because it mixes www.domain.com and domain.com cookies up.

Lastly, if it's a customer trying to login when the error happens, find that customer and delete the contents of their basket. You may want to think about cleaning out the sales quote tables in the database if this is the issue.

2
  • sure, we will try your solution..... – Baby in Magento Feb 22 '16 at 16:51
  • i am trying removing one by one module and checking – Baby in Magento Feb 24 '16 at 9:18

Not the answer you're looking for? Browse other questions tagged or ask your own question.